Relock bootloader step-by-step

Hi all,
After using easy installer and successfully installing eOS I ended up with an unlocked bootloader.
It seems the fact that it is unlocked makes some apps fail the security check and won’t work (netflix for example). As I don’t have a good reason to keep it unlocked I would prefer to get it locked again.

Last time I tried, this wasn’t possible due to some versioning rule regarding the installed security update vs the one being installed. This was back in April.

I’ve now waited a few months until several updates are available and I’m looking for official instructions on how to get my phone’s bootloader re-locked.

Is it as simple as re-running the easy installer? Are there manual steps involved?
the official instructions have a section describing the issue of the android security version but does not mention how to manage it after this has happened.

Any guidance is most appreciated, thanks!

It’s imho even easier (if you have a “fastboot” command on your device - if not you might use your preferred search engine to find out how to install it).


  • shutdown your FP4
  • keep “vol-” pressed while connecting the device via an USB data cable to your computer
  • type fastboot flashing lock

If you want to make sure you won’t brick your device then you can type in
fastboot flashing get_unlock_ability before relocking the bootloader.
If the answer is 1, it should be possible to relock the bootloader.
If the answer is 0, you should not relock the bootloader.

:point_right: Please be aware that relocking the bootloader will factory reset your device (i.e. it will delete all data on it!)



I installed LineageOS20 successfully on my daughters FP4. Can I relock the bootloader in the same way? Yes, I got: get_unlock_ability: 1.

Thank you in advance

Lineage does not support to relock the bootloader…


Oh that’s a pity.
Is there no way getting rid of the warning message at startup?

No, and even if you would be running one of the lockable custom ROMs and lock it you’d just get a slightly less scary warning screen.

Unless you run /e/OS, or build LOS (or any other ROM) yourself and sign it with Google’s test keys, because the bootloader trusts those … :roll_eyes:
Not that I would reccommend that.


Thanks a lot!
So I’d rather prefer to “never touch a running system”.

1 Like

Sadly this is not as easy as it sounds.

Running fastboot flashing get_unlock_ability gave me a positive.

And after running the fastboot flashing lock it now says my device is corrupt and will not boot.

Luckily I knew this was most probably the case when you suggested “it’s even easier”. So I’ll reflash, but be careful giving advise to the people coming new to this.

For more context, I wanted to relock my device after running in the “caution” section from the eos installer for FP4

sigh it’s actually properly bricked now and other threads suggest im screwed and should contact support…


If fastboot flashing get_unlock_ability gives you a “1” you should be able to just unlock it again by using fastboot flashing unlock.

nope. it gives a “0”.
do you have any suggestion on what to do when “the easy way” didn’t work?

I’m very sorry, I don’t know one.
Therefore I had written


you has also written how easy it is despite me mentioning previous issues like the versinioning rule, which if you knew better is that sets the 1 or 0.

So my issue was already described there, but you mentioned its easier as in that’s not a problem. So I thought you being a moderator probably knew better. I blame myself since at the end of the day im the one not questioning it.

But it is also true that you clearly didn’t know about the versioning issue, that you EDITED original answer with the part of the 1 or 0 and later wrote the message that “therefore I had written” which is a cowards escape.

Again, I only blame myself but maybe next time, if someone puts the effort of explaining what they did and what hasn’t worked, you don’t go around boasting “how easy it actually is”.

This post was not updated or corrected, so no idea what you mean when you say

And a moderator is a user using the FP and moderating the forum. The forum us no official support contact.

1 Like