Registered fingerprints disappear with time on GSI

Hello,

I experience a strange behavior with GSIs on my Fairphone 3.

I use a lot my fingers to unlock the phone. I register usually two fingerprints.
But randomly, often after a restart or some time, the registered fingerprints disappear from the list and are not recognized by the phone.

Always one at a time! When I check the Security tab in Settings, at first it says “2 registered fingerprints”, later “1 registered fingerprint”, later none.
I can register back without problem the fingers, never had an error about duplicate.
It’s like they never existed.

This problem occurs on all GSIs I tried: Corvus, crDroid, AncientOS. So I don’t think it’s specific to one OS.
No problem when using “normal” roms: Stock, LineageOS, Iodé.

I tried to install GSI from two bases:

  • If installing GSI after LineageOS, I’ve the fingerprints bug
  • If installing from Fairphone OS, I also have the bug, and my SDXC exFAT card is not recognized (“corrupted data”)

Does anyone have the same problem? Did you find a solution? Thanks in advance.