Recent apps button doesn't work after changing launcher

Okay so, i have a Fairphone 3 with Android10 and I have the three buttons option in the lower bar. I was trying other launchers and i found ones (Nova launcher and Lawnchair) i liked better than the default one (Quickstep). So via USB debugging and ADB i uninstalled Quickstep.

After I did that, the “Recent apps” button (the one on the right, in the lower bar with Back and Home) has stopped working.

I tried to have a look in settings but it seems I can’t change a thing about the lower bar. Also in the launchers’ settings it seems I can’t change anything. I also tried to relaunch my phone and wipe cache but nothing worked.

Does anybody have had the same problem?

Yes, correct.
I did it also. Same effect.
Also that my FP4 stayed black and ended up in factory reset automatically.
You have to leave it on system. Ignore it and use the other launcher.
You have to install it again.

adb shell cmd package install-existing <packagename>

1 Like

If in doubt … com.android.launcher3

Thank you so much, it worked!
Actually with this command

it didn’t work.
So I had to use an alternative one i found online.

This particular one is for FM Radio.
First of all, you search for the path:

pm dump com.android.fmradio | grep path

(Substitute com.android.fmradio with anything else you need, for example I used com.android.launcher3 because i needed Quickstep)
As soon as you get your path, use this command:

pm install -r --user 0 /system/priv-app/FMRadio/FMRadio.apk

(Substitute the path /system/privapp…apk with your path for your app that you saw before with the first command)

Thank you!

2 Likes

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.