Reboots by running OsmAnd navigation on a charging LOS Fairphone2

Just for the record. Today I’ve been navigating for 6 hours without any reboot. LOS 20171004, gps only, no Bluetooth, charging all the time. No reboots, stable as a rock

Update; next day also around 6 hours, including charging from ca 40% to full

1 Like

Hi @lklaus,
nice to hear that it works for you so well! With that I don’t need to give up; may be, I’ll find another cause for my problems? To you I have the request to run Bluetooth while you do your navigation next time. Just switch it on and let it run in the background. Still I have the suspicion, that Bluetooth causes my reboots.

1 Like

Yes, the last two days I needed the navigation, so i didn’t want to activate bt… Will do tomorrow, if possible


I’ve just posted something similar to this on a different topic. I have a strange feeling it’s something to do with charging that causes the reboot (mainly in the night for me). I learnt how to get the last_kmsg.txt file by looking at this article.

2917-10-09: I did a tour on my MTB around some streets, but mostly fields and woods, all together 110 km and nine hours. OsmAnd was on all the time, charging from the hub Dynamo (this time a Shimano one) via Forumslader, Buetooth switched on, location with GPS only, WiFi switched off.
Charging started at 70% and went on untill 100%. Than after 1-1/2 hour a sudden device reboot. I set the device up again as before and it went on running without any interruption for the rest of the day.

I have the same problem as stated here:

I also noticed that the GPS is currently slower and less precise with LineageOS than with FPOOS.

I can be shown offroad, speed can be slower to update, and sometimes exageratly too high (159km/h in a city, or waiting at a red semaphore light).

Hi @siltaar

are you certain you are using GPS only? To me it looks somehow like you’re using cell ids for estimating your position. There are backends which handle this. I have tested cell id positioning with similar results some good while ago.

Hi Amber, thanks for you interest.

I confirm that I’m using the Device Only positioning system.

Previous observations where done with LineageOS 14.1 from the 19 december 2017.

You could use syslog app (from Scott Warner) in playstore. There’s an
option to grab last kernel log.


I’ve noticed that running strava sometimes causes reboots and sudden battery drains. Whilst on a long cycle, I’ll check my phone and notice strava has faulted or I’ve had a reboot. Obviously its using GPS to track my movents.
I’ve posted previously about this here 🇬🇧 🇩🇪 Random reboots with (official) Lineage OS?
Here’s another screengrab of the battery behaviour when this issue happens (from today)

Today it happend again twice, first after 20 minutes, second after one hour. I charged via the bicycles ‘Forumslader’ (a charger for hub dynamos at bikes) and used the ‘Forumslader’ app to watch, what is happening. The FP2 is connected to the 'Forumslader via BT. The phones OS has been Lineage 14.1 version 20180307 without any ad-on like microG or Open GApps.

Now my patience has come to an end. Again I have had reboots again and again running Osmand at my bike, the phone charged by the bikes hub generator.
For me this application is the most important one, but it is most unreliable. Two years of trying to get a solution havn’t been enough time to solve the problem. I started with Fairphone OS, followed by Fairphone open OS and after that with LineageOS 14.1.2, at last with version 20180314 and modemfile 20180301. It never worked satisfactorily.
Now I have decided to sell my Faiphone.

A sad story: I like the phone, I support, what stands behind it, I like the phones concept, the modularity, the freedom, to use different, Google free OSes, I like this awesome Fairphone forum.
But when the phone doesn’t do the main task, I have bought it for, that all together doesn’t help.
Hopefully someone else, who doesn’t intend to use the phone at his bike, will be luckier than me with this exceeding Fairphone!
By by says Heiner

Is it Osmand or is it the phone I wonder?
What happens if you try another navigation app.

Who knows? My next step is to try another phone.

1 Like

Well, there are reports of spontaneous reboots while charging (I had this also, non reproducible, though), and an aggravated situation with charging while navigating (not necessarily osmand).
So, maybe a specific batch of phones, or a firmware problem with location services while charging…
So many possibilities… End of April I’ll have my own share of experience, will see :wink:

1 Like

Now you may judge yourself:
I did another 85 km ride today without any reboots!

I used the same software with a slightly different OS, and the phone has been a different:
A Samsung Galaxy S5 from 2015 with a
Qualcomm Snapdragon 801 prozessor, version MSM8974PRO-AC, a
Krait 400 CPU, an
Adreno ™ 330 GPU and
USB 3.0.
The OS I used is Lineage_klte 7.1.2 microG for the Galaxy S5, version 20180323.
Patchlevel March 5, 2018
Performance profile (accu settings):
at the FP2: ‘Power save’,
at the Galaxy: ‘Balanced’.
I didn’t install a special modem file. The phone is rooted as the FP2 has been.

Another (unimportant?) difference between the phones:
My FP2 is encrypted, the Galaxy is not. I tried to encrypt the Galaxy some time before and ended up with a bricked phone, had to set up it from scratch again.

1 Like

Have you already filed a request to Fairphone for a device exchange?

My household now has two FP2s, mine is an older one with an AB SoC and my wife’s is from a newer batch with an AA SoC. The first one she got delivered overheated instantaneously followed by a reboot, it had to be returned and exchanged. The new device still reboots about twice per week, but we’ll see how it develops after installation of the latest modem firmware.

I never had any reboots while charging and navigating with OsmAnd. My phone reboots rather spontaneously while doing literally nothing once a month. :no_mouth:

1 Like

I tend to believe it is the combination of both.
I have an older SoC AB version by the way.

I have used OSMand and also Navmii with Lollipop. Navmii is fine so far.
OSMand seems to be quite resource hungry and demanding. It drains the battery quick and while charging and navigating the phone gets hot as hell. I did not have any reboots yet, but this heat increase could lead to any kind of strange behaviour of the entire device.

Other phones maybe can take this high core temperature but as it looks FP2 comes to a limit.

I didn’t. In the last time I have had reboots only at this special condition, and I don’t have the impression, that the Fairphone devs have time to care for such special requirements. They won’t ride a bike to collect experiences at it.

1 Like

Probably you are right with the Osmand high power demand. The battery never charged completely with running Osmand, neither at the bike, nor at a car. Even when charging and running Osmand at the car the Phone lost charge.
But in my case the device temperature should not have been crucial: The phone is sitting on the bikes handlebar without any extra cover and the outside temperature has been around -2° C with strong wind force 6 - 9, quite uncomfortable to do a ride. At the test yesterday with the Galaxy I have had light winds and temperature between +5° to +10° C, nice to ride a bike.