Rear camera has 'disappeared'

I have occasionally had the issue others have mentioned where my FP2 can’t connect to the camera. Now a new thing has happened. I can take photos on selfie mode but the option to switch back to the rear camera is no longer there. I tried a different camera app but the same problem occurred. This happened shortly after I had the phone open to replace the bottom module. I didn’t intentionally touch the camera module but I wonder if I’ve somehow disturbed it or maybe it’s just a coincidence.

In case it’s unclear from my original post, I would like to fix this. Anyone have any ideas how to make my phone acknowledge the rear camera?

The first thing most of us here will usually suggest is to unscrew and re-screw the camera module back into place. The screws might have gotten loose, so the module might have just lost contact.


Hi, thanks for your reply. Yeah, that is what I thought too but I didn’t have my screwdriver. I have now been reunited with my screwdriver and tried the taking out putting back in again process. Still doesn’t work.

Probably not want you want to hear but at some point re-installing device firmware might be worth consideration, so that it has fresh chance to capture the camera. On a conventional device you would always discount software issues first before considering hardware ones, but upon FP2 tend to jump in fiddling with all the modules because of the many contacts involved.

What would that involve?

Look at this resource:

Thanks. That looks quite heavy duty. I’ll keep it in mind.

If you have backed up your essential data, it would always be worth trying “factory reset” first via UI before re-installing device firmware if no change.

Ok, I’ll look into that. I was thinking a factory reset might be helpful for other problems as well. I don’t think I have a backup though so I’ll need to organise that first.

One more thing people have brought up as a potential hardware fix is about the two black (?) adhesive rings on the bottom side of the camera module. It has helped in some cases to remove these so there is an even tighter fit between the module and the contact area on the core module. Note: This is not endorsed by Fairphone Support.


Thanks, maybe that’s worth a try.

Factory reset was unsuccessful so I’m back to looking at the hardware I think. I’ve also now lost the camera app that I originally had (not open camera) - anyone know what that might have been? I feel like it was there when I first got the phone. The logo was a white camera with a multi coloured circle for the lens.

I’ve now noticed the torch also doesn’t work so would that suggest it is a hardware issue with that module?

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.