Re: Installing O.S, Bricked Fairphone. Please help


So I tried installing Ubuntu touch from windows using the wizard program, can’t get it to work spends well over an hour trying to flash recovery, fairphone wiped no O.S


So I figured i’d just re:install the o.s, I’ve done it before with phone no fuss no muss… -I think I used some sorta unlocking program- but this time it’s proving to be difficult

I followed this guide but I can’t get it to work so i’m looking for some help.

at step 7 flash command dosne’t seem to work I get the error “fastbook is an unrecognied internal or external command” ( I also note it says to use the sudo command but i’m pretty sure this isn’t a thing in CMD -no offence intended author-)


I want AN operating system getting Ubuntu touch to work would be great, I’ve even considering installing Ubuntu in VM ware to run the other Ubuntu touch installer -though I have no idea whether this would work-

Thanks for your time in advance


I’m sorry, because I can’t help you, but I have a similar problem:

I have installed twrp for rooting my fp2. I have deleted everything and now I wanted to install fairphone OS 17 with adb sideload. The problem is, that

if a take this file:

the mobile says “invalid zip file format”

if I take this file:

it says “ZIP-Datei ist beschädigt” (ZIP-Datei is damaged).

Can anybody help me?

I know that it says “Upgrade” on the download page, but nonetheless you need the OTA file to install the OS using TWRP, as I asked about this once and the OTA file is the full OS.

In TWRP turn off “Zip signature verification” in the Settings and then simply “Install” the OTA ZIP file from SD Card.

The ZIP files with “manual” in the filename are installed with the FP2 in fastboot mode and using ADB + fastboot on your PC.

That file will not install anything.
Fairphone provide the source code for their Fairphone Open OS, so that you can build it yourself from the source code if you want. However, there are parts of the OS (e.g. drivers) which Fairphone can not deliver in source code, so they provide those binary blobs they themselves get from the part vendors for you to include in your own build so there is nothing missing in your own-built OS. Just a layman’s try of an explanation, sorry.

Hi, the problem comes from your computer. It’s nothing, just that you have to tell your terminal where is fastboot. Do you use the script or flash.bat ?

Thanks Theofruitrogue.

I use flash.bat as i’m attempting to do this from a windows machine (windows 10) and in CMD (to the best of my knowledge you can’t get terminal in windows cept maybe be Virtural box).

The guide seems to suggest this is possible and should be done from CMD.

I will admit to being steps away from installing Ubuntu on my old lap top for better results and giving touch another go.

Indeed this should not be a problem, given

  • ADB + fastboot is installed correctly
  • Fairphone 2 is connected to the PC and rebooted into fastboot mode (Volume Down pressed at time of reboot)
  • (for safety’s sake) CMD was started as Administrator
  • in CMD “fastboot devices” outputs a device number (showing the FP2 is found and ready for fastboot)

I think adb and fastboot are not installed but downloaded via the android platform tools. So he just have to modify the script to have the full path to fastboot binary or to install adb and fastboot in windows system.


That was pretty much right, thanks theofruitrogue.

1 Like


thank you very much for the answers. It worked with the ota file!

1 Like