Re-Enter SIM PIN

Hey together,

last week, my new FP2 arrived - and nearly everything is fine with it :slight_smile:
But one or two times a day, i have to re-enter the PIN of my first (and only) SIM-card.

The phone doesnt reboot! When i watch the uptime in the Settings-app, it says over 48 hours uptime (increasing … so i see the phone was not turned of).

Any idea on this? It happens only in the Afternoon, but no exactly time each day. The whole day at work, when driving the car and listening to music via bluetooth and so on is quiet stable! I ordered another SIM-card at my provider, it will arrive next week.

Any ways to debug this one? I would watch logcat, but this would require FireOS Open and root-access, if i´ m right?

Kind regards from Germany,



Hi chmod,

I guess you checked if the SIM card is properly placed in it’s slot?

There are some SIM card types which cause problems, maybe your SIM card is one of these:

Hi Werner,

Since the update to Fairphone OS 1.5.1, I also have “The re-enter SIM PIN” problem.

Gives this a clue?

Kind regards from Holland



I have the same problem now. Installed the update 1.5.1 and a week later i have to reenter my pin several times a day


Since the last update I am also experiencing this problem, about 5 times per hour I need to re enter my SIM PIN and my phone has to reconnect to the network.

My SIM cards are:
SIM1: Ben NL
SIM2: Tele2NL
When I disabled the Tele2 simcard the problem persisted but I only had to unlock my BenNL sim card instead of both sim cards.


I also have a similar problem since yesterday: My FP2 loses the connection to the network very often.

Edit: My mobile networks are
SIM1: Germany / O₂
SIM2: Germany / O₂
Both SIM cards are affected.

Which network are @chmod775, @Kees, @Eric_h, @Matheas using and are both SIM cards affected (if you use two)? So we can narrow down the problem.


Same problem here. Also both of my SIM cards are O2 Germany.


Hey Werner and all the others and thanks for your reply! I was a little busy so i didnt looked in the forum that often :slight_smile:

Yes of course, i checked the sim card and in the meanwhile i tested the new one from my provider - no chance :frowning:

I disabled the pin completely as a workaround so the phone is instantly re-connecting to the mobile network. But since others are having this problem too (phew), i hope for a bugfix.

Any idea how we can debug this problem? I dont know if the developers can reproduce this? :frowning:




Hey tofra,

i use only one SIM (in slot one) from 1und1 (a Vodafone reseller) :slight_smile:

1 Like

I have got exactly the same problem!
1.5.1 and a congstar sim card.

I tried reinserting the sim card several times. I will try and call support after work today…

1 Like

Seems to be connected to using GPS services: as soon as I use Google Maps and use it to show my position I need to re-enter the pin.
Also the same with Pokemon Go: as soon as I start the app, and it begins using GPS, I need to reenter my sim pin!

edit: funny enough not every time.

I disabled the pin completely as a workaround so the phone is instantly re-connecting to the mobile network. But since others are having this problem too (phew), i hope for a bugfix.

Yep… I’m quite happy, that it doesnt seem to be a defect of my fairphone. Mine was switched off for two weeks now, because I had to wait for a new display. I’m quite fed up with defects right now.

Thanks for sharing your workaround @chmod775 . It is so simple, that I don’t know why I didn’t have this Idea :slight_smile:

Got the same problem for 2 days now. sometimes just emergency calls allowed, then pin is requested again and cellular working for a while.Sometimes I have to turn the sim slot off and on again or rebooting the phone. Tried it in slot 1 and 2

1 Like

I’m experiencing the same problem since yesterday. At random times, I need te re-enter my sim pin. I have a belgian SIM which never caused any problems.


Same problem here, started two days ago. FP2 all over sudden asks for the SIM PIN.

  • FP2 1.5.1
  • SIM is in for months, so improperly inserted SIM is unlikely
1 Like

Hey chmod,

Unfortunately it is not possible to undo the update to OS 1.5.1

After this update, my SIM-card is locked randomly (reinsert didn’t help)

Removal of the Pin makes at worthwile to steel the SIM :wink:

Regards, Kees

1 Like

Same problem here. However, it started today and I installed 1.5.1 once it was out - so quite some time ago. I seriously hope this does not mean that the Fairphone is killing my SIM again, see FP2 kills some SIM cards


The Fairphone killing SIM issue was supposed to be fixed, plus the symptoms where different, so I would assume that is not the problem.

Thanks. However, notice that it does not seem to be related to the update to 1.5.1. Also it does not seem to be related to the GPS as I do Pokemon Go a lot and it has started a lot later. So I think being afraid of the SIM degenerating as a reason is not that surprising.

Nice to see that it helps you! Was my last chance not to be offline randomly :smiley:

I can confirm that this issue is also happening with a fresh sim-card, and my old one is not destroyed like the other problem / bug. I think this one is a totally different issue.