Random reboots I cannot figure out why

Just received an OTA update notification : version FP5.TT45.A.141.20240115 seems to fix our problem according to change log!
Fingers crossed : I start the update process…

I have just installed the update and my problem is not solved. However, there may be two different causes.

I wrote to Fairphone support again a few days ago and described my problem.

@jjdekroon Have you been able to achieve anything

Perhaps the problem with the WLAN should have its own thread.

Better, but not perfect yet : I installed the update. Since, I only had one reboot, so it’s 10x better, but not 100% fixed. Happened at home, on wifi, screen off in my pocket.

@423 @jjdekroon
i have in home two different routers with OpenWRT but without enabled 802.11r

  • one is AX, with “SSID_A” for 2.4 and “SSID_B” for 5GHz
  • second is N, with “SSID_C” for 2.4GHz

FP5 auto (re)connect to SSID based on what is better signal,
as this is dumb method, sometime i switch to better SSID manually…

And not have any (unwanted) reboot, using FP5 from 9/2023

Maybe you can test disable 802.11r on routers to check if it will keep restarting?

In my case it is very likely that it is due to 802.11r as I have several OpenWRT networks that I am connected to more or less often. However, it only occurs on the one network that has fast roaming (802.11r) enabled.

Hey Ybb,
I’m testing to see if I can reproduce some reboots with this latest update, could you please share in what conditions it happened? Thanks!

2 Likes

Hi Juan,

It’s hard for me to point precisely, because it happened while the phone was in my pocket.

Conditions were :

  • phone in my pocket, locked
  • at home, connected to one of my two ssid (ubiquiti, wifi 4)
  • connected to 5g
  • 50%+ battery left

I put the phone in my pocket, when I take it out minutes later it had rebooted.

That’s why I haven’t contacted support yet. It hard to reproduce and observe.

But it still only happened once since the update. Which is a loooooot less! (thx!)

1 Like

Hello @Ybb,
It looks like the update at least did something positive on your phone.
This means FP Team at least werw onto something with their latest update.
Can you tell me if you have a wifi-network as well (maybe using OpenWRT), bur definitely using an option 802.11r or fast-roaming in your network?

@423, I certainly have done some expreriments, and at the moment I’m 100% sure the culprit is
802.11r (fast roaming);functionality.
I maintain 3 different networks (my home, the network of my parents in law, and my own parents) whereas I used 802.11r functionality on my own network only previously, I now set-up all 3 networks to 802.11r.
Previously I only had random reboots while at home, now it occurs also when in my parents, or at my parents in law’s place.
So for some people random reboots might have been caused by 5G network switching (in the past before update??), but I’m sure our case lies in 802.11r.
I can also confirm switching off the functionality 802.11r in my networks makes the problem dissappear 100% in my case.
Unfortunately the logs which I pulled from my phone haven’t really been very helpfull yet in understanding what exactly is going on with the wlan-roaming

Hello Juan,

Just copy-ing you in to make you aware of my findings (see post above)
If you need any more information about my testing, feel free to ask.

1 Like

I can also reproduce that it is due to 802.11r.

I have created a second network on the WLAN routers with the same configuration but without fast roaming and the reboots do not occur here.

I do not see the reboot behavior on the other Fairphones (3 and 4) in the network.

I am not sure if the logs I generate with matlog a) contain the error and b) matlog really has access to all necessary logs to detect the problem.
All log files shown end differently and there is no common problem recognizable.

I will also try to use MatLog.
Haven’t used it before, but interested to see if it gathers any more information than I currently have.
If you like me to have a look at the logs, but are afraid of leaking any personal info in there, I can DM you my e-mail address and I can compare with my crash logs.
Like you say, the ending of the logs before crashing differ from time to time, so I don’t even know if the logging system is able to catch it before the reboot already occurs.

I provided my logs to Fairphone Support a few days ago and answered some more detailed questions about my WLAN setup and hope that you can do more with it than I can.

“I will forward it all to our technical department for further investigation.” fingers crossed

I just read the following note in the XDA Developers Forum.

"PLEASE NOTE, THIS DOES NOT WORK FOR KERNEL RELATED ISSUES! Getting the “last_kmsg” from /proc/ is the best method for random reboots and other kernel related problems.
"
Source: https://xdaforums.com/t/guide-easiest-way-to-utilize-matlog.2865994/

It’s 3:30 AM here and I’m not looking at that NOW.

For detailed and also kernel logs call

*#*#0574#*#*

Please try the following via setting in your Router/AP:
Use a channel below 100 for WLAN/WiFi 5 Ghz… then the roaming problem may be solved.

Addition: From channel 100 onwards, special features (such as 160 Mhz bandwidth etc.) are offered.
In the past, some cell phones (also from other manufacturers!) could not handle this - ended up in eternal 2.4 → 5 Ghz changes… or may even reboot.

1 Like

Thank you for that but it dod not solved it.

@yvmuell thank you for that. Can i find a manual or something like that somewhere?

Clearly ! I had no “outdoors” reboots since <3

I wasn’t home to check, sorry for the delay.
Yup, I have two Ubiquiti UAP-AC-LR, and yes, 802.11r was ON. I’ll turn it off and give it a go !

Already on a channel < 100

Thanks everyone for the help. I hope your tips leads me to more peace with my Fairphone :slight_smile:

I dont know about any manual. The logs are saved on the phone and you could probably send it to FP to look into it.

For the issues I had so far I had to use

Capturing ADB logs

  1. Choose “ADB logcat”
  2. Choose “logcat – V threadtime – B all”
  3. Press “start”.

Capturing QXDM logs

  1. Choose “QXDM”
  2. Choose “use default config file” and “1_default.cfg”
  3. Press “start”.

For Kernel are no selections available.

4th day with 802.11r disabled. No reboots since. Will continue watching this…

Thanks @423 for the tip.