Quick access, setting, developer options, app update, and more, broken randomly after restart

I finally gave up and wanted to factory reset. When I did, the phone got stuck with the teamwin screen. Switched it off and on and everything was as bad as before (no reset happened).
So to summ up: I can’t factory reset and I can’t enter system recovery. Both end up with the forever teamwin screen. WTF.

Is there a way to just wipe this entire POS?

update end


I restarted my phone, since I ran into a problem (a call would not connect for some reason) and that usually solves things.

However, now the following things don’t work anymore, which used to be just fine, before I restarted:

  1. my quick access is broken. When I swipe down once from the top it only shows one row of (six) options. I used to be able to swipe down twice, to expand the menu. Now, I can’t access Bluetooth, position, flight mode, etc.

1.1 side note: when I pick “cellular data” for example. Then that remains the only option for quick access and I can’t see the other five anymore, no option to return to “default”

  1. I used to be able to click on the square in the lower right corner and it would show all open apps. Not anymore.

  2. Developer options: when I want to access these, all it says is a white screen with “Developer options are not available for this user”.

  3. I don’t get any notifications anymore

  4. Updating Podcasts works, but the download icon doesn’t show on, as it usually does, on the top of the phone

  5. Updating apps does not appear to work. The Status gets stuck on “Download pending…”

  6. Can’t connect my phone to computer. Which makes it impossible to create a local back up. Great. I hope ANOTHER “factory reset” is not the only solution to this problem .

  7. Not getting SMS. Good bye 2FA accounts…

This is what I discovered so far. Otherwise the phone seems to work.

Restarting Did Not Solve This Problem (DNSTP). Switching on/off including removing the battery DNSTP. Changing from Nova Launcher to default also DNSTP.

System settings: Android 7.1.2

Any help and suggestions welcome.


Edit: Added more problems to the list

How about switching on/off including removing the SIM card? (And inserting it again.)

Thank you for your suggestion. I have tried that too, but forgot to put it on the list.

I think before waiting for too long on a solution that might not exist I might just do another factory reset. At this point it is probably fair to say that I spent more time on this phone doing factory resets, than actually using it to talk to someone (which originally is what phones were invented for).

Be aware that the factory reset on the Fairphone 2 doesn’t touch the OS, it only deletes user data and Apps.
Whether your problem is caused by Apps could perhaps be tested in #dic:safemode.

If you need a really clean break, here’s how …

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.