Quick Access menu gone / touchscreen and keyboard acting Halloweeny

Please note that I believe this is not the same problem as in apparently similar threads (e.g. keyboard not working until gapps reinstalled; or screen detecting nonexistent touches)…

A couple of days ago I noticed that the keyboard was a little
uncooperative, e.g. registering an ‘l’ instead of a backspace in
landscape orientation, and arbitrarily breaking up one word into many in
the ‘swipe’ typing mode.

Today it has got worse. First, I was suddenly unable to bring up the
Quick Access menu from the edge of the screen. Swiping in from the
right, it doesn’t even appear - it simply scrolls to the next
homescreen; from the left, it appears under my finger but immediately
disappears as soon as my finger moves towards selecting any of the five
possible choices. Initially I was able to select Phone when I swiped in
from one very precise location on the edge of screen, but even this
limited functionality is now lost.

This means that I cannot access the Phone, Messaging, Camera or
Browser, or the App drawer (which specifically has now caused further
complications). In addition, while swiping through the regular
homescreens is possible, strangely I cannot select any app icon that
happens to be on the leftmost column on each homescreen. Instead, when I
tap them, the Quick Access menu again appears and then disappears.

Of course at first I tried Restart, twice, with no change. Then Power Off, waiting, then powering on, no change.

Initially I went to the Fairphone Help forum section to find out if I
was alone. While I was typing in a dialogue box, the keyboard went
crazy, flickered, and typed some seemingly random letters and symbols.
After that (it seemed), certain keyboard letters (at the edges of the
screen in both portrait and landscape orientation) either did not
register my touch at all, or activated adjacent letters or buttons (e.g.

At that moment it felt very much like some malicious software had
arrived on my phone. With this in mind, I managed to launch the Play
store via the Settings menus, and installed a Norton antivirus (a quick
decision, as I use Norton on my laptop). Frustratingly, because of the
left-side-of-screen problem, I was unable to tick the box to Agree terms
and conditions, so could not run it. Luckily, McAfee’s app was laid out
differently, so I could run that after installing it, but it found
nothing suspicious.

Some threads on this forum gave me the idea that the problem might
be solved (at least temporarily) by going back to a previous OS using
the Fairphone Updater. This I did, going back to Chen Pi 1.5.

Unfortunately, not only did the screen problem remain, but also I
started getting a message that the Android keyboard had stopped. This I
solved with the Clear Data button in the app settings for the android

But I read that such keyboard problems would persist until I
reinstalled Google Apps. But how to do so, when I could not access my
app/widget drawer to drag it to a homescreen? Finally I realised that I
could get to the drawer via the My Apps widget, which I did. But when I
tried to drag the GApps Installer widget to a homescreen, there was ‘not
enough room’, but my screen malfunction got in the way again: it would
not let me drag the widget to another homescreen, instead displaying the
(unuseable) Quick Access menu for a moment as my finger approached the edge, and then dropping

In a desperate attempt to make room for the GApps Installer on that
homescreen, I held down on the My Apps widget to try to move it to
another homescreen, but the screen malfunction again outfoxed me by
bringing up the Quick Access as my finger approached the edge of the
screen, and then dropping it, with the result that the My Apps widget
was dropped on on ‘Remove X’, deleting it from my homescreen!

Without My Apps, and with the screen problems still an issue, now I
really cannot access the app drawer, to reach the widgets and the GApps
Installer, so I have no GAPPs and no way to install them. And a
touchscreen that seems to hate me and my innocent fingers.

Sorry if there was too much detail in this saga.I could not (and
cannot) find anyone online with the same problem, except some whose
screens register touches as swipes - but it’s not the same.

I have already submitted this little essay to the FP support people, but I wondered if any kind souls out there might be able to offer any advice?

All the best.

Hi @Edward,

if i understand you correctly, your touchscreen no longer registers touches (and swipes) on the left side of the screen correctly?

I assume you already tried reseting to factory settings?

There is on think you could do to trying to understand what is the issue here: If you can manage to go to Settings -> Developer Options.
Enable Developer Options, find Input -> Pointer location and enable it.

This should give you a “pointer” on the screen and draw lines along the way you move your finger on the screen. You can easily very that touches on the screen get registered properly or at all.

The screenshot shows how that looks on my Fairphone when drawing circles:

If you are unable to get pointer locations on the left side and reading what you wrote it appears so, I would guess your touchscreen is somehow damaged. If you have not dropped or soaked your Fairphone hard, this is probably a manufacturing issue. The Fairphone support should help you out here.

1 Like

Thank you @ben, this is much appreciated. I had not resorted to a factory reset - I wanted to see if there were other options. But this morning I have tried it, with no improvement.

The Pointer Location suggestion was very helpful. Thank you very much. Now I can see that no touches or swipes are registered at all down the right hand side of the screen (in portrait orientation), up to a distance of about 5mm from the edge - this is why the Quick Access does not appear at all when I swipe in from the right.

On the left, however, there are a few responsive pixels at the very very edge of the screen, but then there is a vertical ‘band’ of no response, also I guess about 5mm wide. This explains why, when I swipe in from the left, the Quick Access menu at first appears, but is then dropped as my finger enters that unresponsive band. When I tried drawing circles like you, I got broken arcs.

If the phone had been dropped or gotten wet, then I might expect this kind of problem, but I haven’t dropped it or got it wet.

Many thanks again for your quick reply. I will append this new info to my message to Support.

You’re welcome.

Good luck with support!

Just FYI, I had a similar case. If you boot to factory mode, you can also run a touchscreen test, which shows little squares on outermost the sides of the screen - an in my case, the lower three lines, plus the capacitive buttons, did not work.

I sent it in, has been at rePod for about eight work days (+two weekends), and is on the way back, with the message from support:

Your phone is as good as new and ready for you!

Looking very much forward to receive it. Since they did not contact me to ask if I would cover repair costs, I assume so far that the repair was done under warranty conditions.

Hi Edward,

You are not alone! I’ve been having exactly the same issues with my fairphone as you did, I just couldn’t explain it that well. I tried factory reset and hard reset and whatever else was suggested but to no avail. I now cannot use the phone at all since the touchscreen won’t respond most of the time (and I did not drop or damage the phone). The Fairphone helpdesk has now asked me to return the phone for the repairshop to have a look at it. Fingers crossed they’ll be able to fix it…

1 Like

@humorkritik @harvey I sent my phone for repair around 15 days ago. I have just received a message like humorkritik’s, saying my phone is on its way back to me, as good as new.


after working two month, the touchscreen of my Fairphone (2. batch) started to not react, beginning on the left side. Every day the dead area was growing more and more to the right side. The phone was never fallen down before nor I had done any update before nor it was correlated with the charger, the malfunction just started for no reason.
The dead area could be seen exactly when you enter the factory mode->manual test->CTP test. I took a photo from this test screen and sent it to the support. 4 days later the support sent me a RMA number and I had to send the phone back. After two weeks the phone was repaired and as good as new. Thanks a lot to the support team (in particular Ramon and @Sietse) and the fast reponse.
Maybe this will help other user with similar problems to shorten the bug finding process.
Cheers, Mari