Problems with dual SIM card functioning

I have two SIM cards in my Fairphone 2. I’ve instructed the phone to use the SIM 1 card for phone calls, texts and mobile data but phone messages and data usage are still being dealt with by the phone operator for the SIM 2 card. Why is this?

I guess that your SIM 1 is set to 2G and your SIM 2 to 3/4 G
Could you check the settings for the two sims?
Go to 'Settings’
go to 'More’
go to 'Mobile networks’
now you can see the two SIM by their name.
At one SIM the word ‘Perferred network type’ is black.
When it is black, then you can change the setting.
Check if your SIM 1 is set to 2G and your SIM 2 is set to 3/4 G
You can’t have both sims on 3/4 G.

Dear Lidwien,

Thanks very much for taking the time to reply to my question. I’ve discovered something strange when following your instructions - the SIM 1 option is live for the prefered network type and text on the screen says ‘Preferred network mode: 4G (preferred)/3G/2G’ . For SIM 2, the preferred network type option isn’t highlighted (it’s shown in a light grey colour) and I can’t activate it.

However, I’ve selected SIM 2 for my preferred network for calls, mobile data and SMS messages.

What does this mean? Could it be the reason for the problem and also why I can’t get the phone to connect to the Internet unless it’s in a WIFI spot?

Best wishes,

Caroline Aistrop

You have to choose which SIM gets 3/4G.
You can’t have both SIM on 3/4G.
If you want to set the second SIM to 3/4G, then you have to start with setting the first SIM to 2G followed by setting the second SIM to 3/4G.

1 Like

Thanks again for that, I didn’t know how to change the preferred network for a SIM card but experimented and found that it’s simply a case of tapping that option (I’m a single, working mum with no-one to show me how a mobile phone works, or have the time to play about with it and the manual is useless). Have now done that and sorted out the APN available and it now connects to data roaming. Hurrah, at last! I’ve had the phone 18 months and haven’t been able to sort this out so thanks for your help.



1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.