Problems flashing MicroG Lineageos

Hi all,

I encouter an issue when trying to flash microg lineageos fork. I did wipe system cache and dalvik and then tried to install the zip file but I do always get a error 7 message.
(I run twrp 3.2.1.0, and i am coming from lineageos 14.1)

Thanks for your help in advance.

If you are coming from official LineageOS, then you need to flash the migration ZIP before flashing Lineage OS for microG.

Make a backup first and see the instructions in the “Dirty install (keep data and installed apps)” section here: https://lineage.microg.org/#migration

1 Like

Hi Roboe,

thanks a lot. I do understand that if you do a dirty install you have to flash the migration zip first, however, I wanted to do a clean install that is why I wiped cache, data and calvik first. I thought that in that case there is no need to flash the migration zip first.

Oh, someone skipped data in the first post, :angel:.

Indeed, you are right. In that case, it shouldn’t be necessary to flash the migration ZIP at all.

Hmmm, maybe your ZIP is corrupt. Try to redownload from https://download.lineage.microg.org/FP2/ and check the sha256 sum if possible (sum checking ensures the integrity of the file, so no corruption).

Hi Roboe,

sorry I forgot to mention that I wiped data as well…

However, I checked for the hash sum and the file integrity seems to be fine. Still, I get this error 7 message when I try to flash the zip.

I also just realized that after wiping the data partition most of my settings are still there, like the wallpaper I set. That should not be the case after wiping the data partition, right?

Any ideas?

Thanks in advance.

Don’t worry, :slight_smile:

Right. That data should be wiped entirely. Do you have encrypted storage, right? Is TWRP asking for your PIN number or password at launch to decrypt it?

Encryption is a source of problems for #dic:customrecovery/ies*. Try to chose the option WipeFormat Data in TWRP, which will wipe the storage and disable encryption alltogether. Then, try to flash the LineageOS for microG ZIP. If it success, don’t forget to re-encrypt your storage from inside the Operating System (PreferencesSecurityEncryption)

*= I’m not arguing against encryption. Everyone should encrypt their phone storage! I’m a defendant of the universal right of privacy (which enables freedom)

1 Like

Hey guys,

I had a similar problem when I moved to microg a few weeks ago.
I also wanted to do a clean installation, got an error message (don’t remember if it was error 7) and somehow my phone didn’t seem to really be wiped after my failed trials.

So here’s the solution that worked for me:
I think that the LOS version that you want to migrate to has to be newer than the one installed.
Since I was already running the most recent update I had to install an older version of LOS without microg, afterwards I clould migrate without any problem.

2 Likes

Hi all,

@DerJuelz unfortunately first flashing an older LOS did not do the trick for me.

@Roboe My phone is not encrypted. I would however try the format option. But I am not sure if this would also format my internal storage or is it only formatting the data partition?

Thanks!

Sorry to hear that. Let us know whether or not it worked after you tried the format option.
In my case I also did a reset of the internal storage before I moved to LOS with microg.

Yes, the Format Data will wipe your internal storage too. It is like a factory reset: an integral option for clearing all user data, fixing storage and disabling encryption.

So, I made it!

Unfortunately, the format data option also wiped all the data on my sd card. Hence, I had no zip file to flash. I also struggled to get adb sideload working (was an USB cable issue). But finally I could flash the microg LOS which is now smoothly running on my FP2.

Thanks for the support!

2 Likes

Congrats! That was hard. Enjoy LineageOS, :blush:

Just for the record: if someone reads this in the future, you can transfer files regularly from your computer to your device in TWRP enabling MTP with the MountEnable MTP option. Don’t need to struggle with adb sideload or SDK things. Sorry for not foreseeing that, @Nya

We’d need to figure out why TWRP is not correctly wiping data when commanded, after various similar reports here in the forum. Any idea, @z3ntu? (Hope you are not in you final exams… Good luck if you are!)

1 Like

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.