Problems at installing twrp

Hi guys,
Can you please help me with a problem regarding installing twrp.
Unfortunately super basic but I’m stumped right now.
I follow these instructions :

I go into fastboot mode and try to install twrp:

fastboot flash recovery .\twrp.img
Sending ‘recovery’ (10406 KB) OKAY [ 0.331s]
Writing ‘recovery’ OKAY [ 1.061s]
Finished. Total time: 1.404s

Unfortunately I get this error message:

fastboot boot .\twrp.img
Sending ‘boot.img’ (10406 KB) OKAY [ 0.325s]
Booting FAILED (remote: ‘bootimage: incomplete or not signed’)
fastboot: error: Command failed

When I try through the power button and volume up. I get an error display on the phone.
It would be nice if someone could tell me what I’m missing or where I’m being stupid.

greetings peter

This can suggest that your TWRP image download wasn’t 100% perfect. You may try to download it again or try a different TWRP download instead (as long as it’s newer than anything starting with 3.1. …)

1 Like

That’s normal as the TWRP you’re trying to install is not digitally signed (and so can be installed but can’t be used to boot it while in fastboot mode).
What’s the “error” displayed on the phone when you try to enter the flashed TWRP image?
Did you just try to enter TWRP after flashing it? If you first started your phone it may be back to standard recovery.

EDIT: btw.: if you really want to boot a TWRP image (and not install it) you’ll find signed images here: https://fp2.lrnz.org/twrp/

5 Likes

Hey,
thank you for the answer.

I had already tried one of each of the 3.X versions. None of them worked. I even checked the signature which was correct. I don’t know if a corrupted file would also result in a corrupted signature. But I can also exclude that. signatures were okay.
(obtained from this site)

Now I tried one from the US server. It worked !!

Thanks for your help man.
I don’t get it. but somehow the US-Server was it

Doubtful, since

Judging by your opening post @Volker got it right.

You did fastboot flash recovery .\twrp.img, and this worked without an error message.

Then you tried to fastboot boot the same image you just flashed to the phone, and this doesn’t work on the Fairphone 2, for fastboot boot it needs additionally signed images, see #twrpwoflashing. You didn’t have such an image, so fastboot booting failed.

If you mean the Android robot with the open hatch and the “no command” message, this would be the stock #dic:recoverymode (<- see link on how to navigate there), but this would mean that the stock recovery got restored as TWRP couldn’t make itself resident.

Did you unintentionally boot the old OS inbetween when trying to boot TWRP? Then this would have restored the stock recovery.

In general, for TWRP to make itself resident you would have to boot into TWRP right after flashing it.
At this stage in the install guide, Point 6 might well state “Alternatively, on some devices and recoveries you can use fastboot to boot directly into the freshly flashed or any other desired recovery” … but note the “Alternatively”, and the Fairphone 2 is not such a device.
This passage most probably comes from a template all device install guides originate from and should be removed for the Fairphone 2.

So the thing to do on the Fairphone 2 would be to flash TWRP, then to reboot or start the phone with Volume + pressed to boot right into TWRP after flashing it.
To this end, the install guide says just to hold Volume + together with Power. Keeping the power button pressed forces a reboot after approx. 15 seconds, so this does the job.

2 Likes