Problem with superuser and making an Sd-card writable

I rooted my FP 2 and probably it didn’t work out exactly as it should.

I could install superuser and I activated the PIN-Security. When I run Root Verifier it ask me the permission but not the PIN of the superuser app. Why do the phone forget it?
Root Verifier shows me that the phone is rooted - but see in the pictures.

Then i tried to make my sd-card writable on several ways - as discribed in following post : Root with superuser.

With sdcard fix I got this failmessage:

When I try the way with busybox, it’s possible to look into the /system/etc/permissions/platform.xml file but there is no such entry as “write_external_storage”. I can’t even add it because I only have reading acces.

On the longer way, i’m able to edit the platform.xml file but i cant flash it back to the phone. i got this error:

Kais-Thinkpad kai # adb push platform.xml /system/etc/permissions/platform.xml
failed to copy ‘platform.xml’ to ‘/system/etc/permissions/platform.xml’: Read-only file system

What did I wrong?
Thanks a lot for advices

This topic was automatically closed 183 days after the last reply. New replies are no longer allowed.