Problem with Fairphone FP1 running Waze

@DonatCallens Thank you for your comment. See my answer @Lidwien. Why should navigation be dependent to the micro USB cable been plugged-in?

@ben Thank you. My only concern with your post is that using a bicycle and using a car are two different test cases, the latter achieves higher speed and behaves differently on the road. So I am inclined to conclude that they are not comparable :worried:. Also, regarding the cable, see my comments to @Lidwien and @paulakreuzer.

In your PS, you gave the example route. Is this some clever way of tracing the process of the actual navigation you received or you did it with googlemaps to simply illustrate that the route was not trivial.

Not the app is affected but the GPS receiption seems somehow be affected when the cable is attached. I don’t know how that happens and if it happens with every cable or device, but it certainliy seems that at least for some users, GPS works not reliable with a charger connect.

Regarding the suggestion to try another app, this is mainly to help us and you to diagnose the issue: If other apps are also affected, it is likely that it is not Waze causing the issue but the phones hard- or software.

You are right that the test cases are not comparable. But this still shows that there is no general issue with Waze and the Fairphone. You are right regarding speed and futhermore this is also affected by network receiption (for a fast A-GPS fix), wheather condition and exposition of the GPS antennas which are certainly more “covered” in a car compared to a bike.

The route is send is recorded with “My Tracks” from the Play Store made by Google to track sporting activities. It is the actual route i have driven and i uploaded it to show that the Fairphone GPS can work pretty exact. You can see me changing from road to bicycle-path for example.

If your experience is not related to the charger, it might be related to some software settings we have not found yet. Since i am running the latest Beta version, it might be there is a bugfix included you do not yet have.

@ben The app is affected because it calls the GPS api. Therefore, the root of the problem is the GPS, which means that this is a h/w problem, which results from the GPS not being adequately tested. So we cannot possibly ask people to change cables without identifying the h/w problem and solving it by rigorous testing. Unless I am getting something wrong here?

Yes please try another app to see if the problem occurs only with Waze. I for example have made the experience that some apps like OpenWlanMap mess with my GPS. If I just got a fix and then turn on OWM I loose the fix and getting it back even takes longer (up to 5 minutes) than the first fix. As a workaround, since I really like OWM, I turn it on before getting GPS fixed. The first first fix will take only a little bit longer (like 20 instead of 2 seconds) and it will work fine then.
About the cable: Many users posted on the forum that cheap cables can mess with the GPS wich can result in GPS loss when plugging in and/or a much longer TTFF.
The Fairphone team surely did test the GPS rigorously but surely not with all different cables available on the market.

Oh and if you reply to many people at once please do so in one single post the next time. You can start each paragraph with the name of the person you are answering to.

@ben Ok, I buy that and I will download another app to test it. But surely, at least for the h/w functioning, one might consider having a s/w test to do this. A bit like the tests you have for routers. But here you are asking the users. In other words, you are asking the users to be testers. I think it would better if you tell them that before they buy the phone and tell them the problems they will be testing. Otherwise, cheating will have the opposite effect i.e. loosing users. Am I missing something here?

Ok, I have download it and will test it. Can I for example start that while I am running Waze and then stop it when I arrive to my destination?

I like to know what is this setting :angry:, I promise you Ben. Let’s see. More tomorrow perhaps.

Will do, apologies Paul.

There is something called electromagnetic noise or interference. Since the GPS signal is an electromagnetic wave it can be disturbed by the electricity going through your charging cable.

I think it is similar to the phenomenon that your FM radio has bad reception when you use a wall charger, which is not grounded (like I do).

Possibly. Most people active here on the forum are not FP employees because the forum is led by the community. Also the community moderators are not employed by FP, but users like you.

No need to buy anything, you can use My Tracks which is free, or Nokia Here for example which is free as well, or OsmAnd which is also free (and free/libre) if you download from If you use Nokia Maps, make sure you download the offline maps (also free) to reduce the amount of data use.

This is what we try to test here. I can, but not necesseseraly has to be a hw problem.

Exactly. We are all just users or supporters of the Fairphone, this is not the official support channel. And we fully appreciate that the things we ask for require some work and do not necesseraly help. But we try to help with different ideas, one of them trying a different app, another trying a differen cable, checking your settings etc. Two of us installed and tested Waze just to try to help you.

No need to buy anything[/quote]

I think in this case “to buy it” means that you got something, that you understand. :wink:

1 Like

@paulakreuzer @ben I installed Navmii and it had exactly the same problems as Waze. So the problem should not be with Waze. Could it be a problem that the GPS has with evaluating speed and location from satellite data? Any further ideas are welcomed.

@Stefan thanks for explaining the problem with the USB cable clearly. However, how is this not a problem with phones like the iPhone. Does this mean that one needs to be clear about the notion of “openess” for USB cables - i.e. that there will be some USB cables that if we want to reuse they will mess things up for some services? And if they are, what is the point of using them - are we not shooting ourselves in the foot? Which means that one has to set up a standard for USB cables, and reuse has to conform to that standard, if QoS is important. Otherwise, all hell breaks loose.

The iPhone’s charging cable has a qunique Apple design, so every cable designed that way is supposed to work with the iPhone or iPad. The Fairphone on the other hand uses a standard Micro-USB Cable, because since they believe most people have such a cable they don’t want to send cables to everybody and increasing the e-waste pile.
The downside is that some cables that fit the Fairphone don’t work perfectly with it, because they were designed for different devices.

I’d install SatStat and try to check - at a moment when your location is not shown correctly - if it shows a good GPS connection (number of connected satelites) and accuracy (meters error; <5 is good). If the stats are bad then you have a problem with GPS connection, if they are good then it’s a problem with location calculation.
If the connection is the problem and none of the tips in the GPS Guide helps then you might want to try an alternative Guide like this one I found. (It involves totally turning off A-GPS and EPO Assistance and going out and waiting for a long time to get an unasisted GPS fix. The author claims that after this GPS will work better than A-GPS)
If the problem is the location calculation and the Gravity Box trick doesn’t help maybe you should contact support…

1 Like

I found that using a USB cable with ferrite rings works better then without. I suspect the 12 volt to 5 volt regulator produces high frequency noise on the cable that the FP picks up. Useing the GPS test app you can see the signal strength of the satellites change when plugging in the cable. Try this.

1 Like

Apart from the charging cable, I experienced that navigating/using the GPS is a rather cpu intensive task. I noticed that navigation with the phone while the facebook app was installed was terrible. When I removed facebook all went much smoother. The facebook app is cpu hungry.
Also when wifi is on, the phone is constantly looking for accesspoints. This also eats away on your CPU. While driving through the countryside this is OK, but in domestic area´s there are loads of accesspoints it looks at, especially if Wifi is also used for location services.


That’s a good point, a buisy CPU is definitly not helpful.

About Wifi: I only made the experience that using Wifi/Network Location Services is helpful, but of course if GPS connection is lost and you have NLP activated that can easily cause your device to believe you are on a paralell street. NLP is not very accurate, especially when you are not near a Wifi, because then your location is only calculated with cellular networks.

If you turn off NLP and your GPS connectivity is lost I guess instead of putting you on the wrong street you’ll just not move at all. So yeah @KostisS try it without NLP (Settings > Location Access > unick “Wifi & mobile network location”) and report back if that helps.

@paulakreuzer I have tried what you suggested with NLP and did not work. I also tried your suggestions with the GPS guides and the one that mentions YGPS (and spent all day yesterday testing). None of them works :frowning: - I think something must be wrong with the phone. How can I contact support. Can I do it via here?

Yeah the contacting Support is probably the right thing to do.
The Support link is on the top right of the screen, at least if you are not on mobile as I am right now. There is a button, which says “Submit request” or “Contact us” or similar.

It could also help, if you send them the link to this discussion, so they see, what you have tried already to solve the issue.

1 Like