English

Problem while installing LineageOS (Zip signature verification failed)

lineageos
Tags: #<Tag:0x00007fefbb80bbe8>

#1

Hi
I have seen the previous topic to the subject, but it doesn’t solve my problem. So I reopen the topic. I have wiped the phone and unchecked the “signature verification” checkbox. However, I still have the error message “Zip signature verification failed, Error installing Zip file lineage-15.1-20190216-nightly-FP2-signed.zip… Updating partition details… done.” If I reboot, the phone stops loading at the “Fairphone” screen. I assume there is no installation in progress… Any help? I have several Wipe options: “Format Data” and “Swipe to factory reset” what’s the difference?
I tried both, but no success.

Thanks a lot, Markus


#2

Make sure you use the current TWRP version from twrp.me as advised in the LineageOS installation guide. The older TWRP version bundled with Fairphone’s OSes is known to cause some trouble here and there.

A “factory reset” on the Fairphone 2 will delete user data and Apps installed by the user (yeah, it is not a factory reset in the sense of the term), the OS will be left as is and upon the next boot will restart the initialisation process as if it was newly installed (which it wasn’t).

“Format Data” goes a step further than wiping does. Formatting data doesn’t only delete files, it really formats the data partition. Not only all user data will be gone, but if the data partition was encrypted (that’s what encrypting “the phone” really does), encryption will be gone, too.
Formatting Data also will not touch the installed OS.

If you want to play it safe and really install from scratch, here’s how … for Fairphone’s OSes anyway, but you can continue installing LineageOS after the “Format Data” part in the guide …


#3

Hi AnotherElk
Thanks a lot for the quick help! Indeed, it was the TWRP which was outdated. I did not manage to install the apk file of TWRP with adb on my computer, but I found the Image file of TWRP an simply copied it onto the SD card of the phone. After that I installed the image file with the TWRP already in place. After that, no problem in installing the zip file. Lineage runs fine :slight_smile:
Thanks an good night,
Markus


#4

Hey guys,
sorry for being late to the party, but I wanted to emphasize that it is important following the steps from the lineageos wiki about installing. Stupid me thought it is unnecessary wiping the cache and system partitions, installed the latest version (zip verification included, solved by upgrading twrp) could boot up but ended up in a loop. Following the steps precisely helped and since yesterday I am a happy FP2 owner using lineageos with f-droid - thanks