Problem connecting Fairphone 2 to PC

Hi Everybody,
I hope this is the right place of the Forum where to ask help about my issues.

I have been trying to connect the phone with an USB cable to my LapTop (Windows 7 is the Operative System) but i can’t access to the phone as a Drive Store.
It doesn’t pop up any Icon or Directory…

I did try with different cables, and I tried with a Mac too but still nothing happen!

Another problem then is:
How i can remove the vibration when i text a message.
For any apps (What’s up, Telegram, SMS one…) it does keep vibrating for each single touch I do.
I tried to check in the Options with no much luck!

Please Help!

:slight_smile: Peace

The title “FairPhone VS PC” is not very useful (this actually implies a comparison between the FP2 and a PC). I changed it to “Problem connecting Fairphone 2 to PC”.

Turn it off in Settings - the menu item with the bell (“Sounds & Notifications”) - the menu item directly above “Privacy Impact” (“Other Sounds”) - turn the last item (“Vibrate at touch”) off.

I have the German language, so the menu item names may not be accurate.


concerning the connection problems: once your fp2 is connected, you should get an entry in the notifications, that your device is connected via usb. if you tap it, you can chose which components you want to use. Please make sure you have the internal storage checked and ideally all the other items unchecked. Normally this should be sufficient to establish a connection and mount the memory on your ohone.
Best regards,


To switch off the vibration of the keyboard, go to stettings–>Language & input–>Android Keyboard (AOSP) -->Preferences, and switch off “vibrate on keypress”.
About your connection problem. When you plug in your phone to the PC, have a look at the phone’s notification bar (at the very top). When you swipe it down, in the top left corner there should be a menue with usb options. Select MTP and it should work.

Hi Tofra!
Thanks to fix the title and thanks for your tip. I did already turn off that option but it is not doing anything!
It does still vibrating when i text, that’s why i was asking for some help :slightly_smiling:


Did you check your USB cable using another phone? I have some cables that are “charge only” and won’t make a data connection (including one I bought at an airport which was called “micro usb data cable”.

There exists another setting:

  1. Settings
  2. Language & Input (menu item with globe)
  3. Android Keyboard (AOSP), fifth menu item
  4. Settings (second menu item)
  5. Vibrate at Keypress (third menu item)

You got it Tofra!!

This was the one :slightly_smiling:


Thanks Irina!
It did work :slightly_smiling:

1 Like