Problem: Audio does not resume at where it was paused

With most of my apps dealing with audio (most notably pocketcasts and poweramp), the player does not resume at the time instant where it was paused. It usually jumps to somewhere near the beginning.

I contacted the makers of pocketcasts and they said it was an issue reported to them before by FP users, and they could not help it.

The recent update of the FP OS did not resolve matters.

Another thread reports the same issue, but without resolution other than using different apps.

But I don’t want to use other apps, because I like these and I already paid for them.

Any help from the FP-team or other users welcome, thank you.

I have moved this topic into the Fairphone Help! category so that it will be more visible to others in the community and hopefully we will get you an answer.

A question from me though, have you tried using a different (free - obviously don’t expect you to pay to try) app to see if the audio plays correctly on them? I’m using Google Music and I’ve not had any problems with this either from the handset speaker, headset or bluetooth. I think it is worth establishing more detail on where the issue is coming from - and if it is a bug we can then get this reported up to the Fairphone Support team.

Thank you.

I have just tried antennapod, and the problem persists.

Using replay on the native soundrecorder app seems to work without issues.

Note there is no difference how it’s being played (handset, speaker, bluetooth), it’s the same problem. It also does not matter how I pause the episodes (within app, headphones, widget). It usually occurs when the pause is longer (hours, days), but occasionally also occurs when only minutes have passed.

This is what the pocketcasts team (Shifty Jelly) wrote back to me in May:

“Thanks for taking the time to email us. We’re aware of this issue
and it seems to be specific to the Fairphone. I’m currently in touch
with the developers, attempting to arrange a Fairphone to test on.
Hopefully we’ll be able to get our hands on one soon and look into what we might be able to do about this.”

I will contact them myself again if they have made some progress.

Anyways, hope anyone else can help, thank you in advance.

Just a “me too”, I’m having the same problem with Pocket Casts. Just on the Fairphone, not on another phone I’m using. In my experience it happens less often when pausing on Pocket Casts’ now playing screen, but always (and immediately) if pausing on the lock screen or using the drag-from-top menu (don’t know what the proper name for this is). Interesting that it happens in poweramp as well.

Just received a very helpful email back from Shifty Jelly (developers of pocketcasts). They said they found another fairphone user with exactly the same issue and in his case setting playback to 1.1x speed fixed all of the issues. To them this confirmed that it has something to do with the native player on the fairphone phone.

So, follow-on question 1: how do I set playback to 1.1x speed as a temporary workaround? Tried hard to find it, but no luck as yet. Any ideas?

Follow-on question 2: how to report this as a probable bug?


Thanks for the update - I will get this reported as a bug to investigate with the Fairphone team.

This might be of use for helping to change the playback speed settings

Ok thanks. I managed to change the playback speed settings in pocket casts. Will report back wether the problem has disappeared or not.

Looking forward to the bug-fix!

Sofar the problem with pocket casts has not occurred using playback at 1.1x, so … good!

Now I also want to use the poweramp app, where there apparently is no possibility for an increased playback speed .

So - keenly awaiting bug fix! Thanks.

1 Like

I experience the same problem and did some Google research.

My conclusions:

  • The problem is the Mediatek 65xx CPU. (You can find not only Fairphone users with this problem, but also users with other phones having the Mediatek CPU).
  • Therefore, as already mentioned here, the problem is “inside” the internal audio player. (The problem persits even after several factory resets and with lots of different apps).
  • Workaround 1: Use an podcast app which allows to use a different 3rd party audio player.
  • Workaround 2: The podcast app “Podcast Addict” has a special option for MT65xx users.

Thanks for the tip for using playback speed 1.1!


I have been having the exact same problem for ages and assumed it was the app at fault until I switched apps and the exact same issue repeated itself. Many thanks for your very useful thread! Will try the 1.1x fix. Thanks

1 Like

Unfortunately, neither the 1.1x speed fix nor Podcast Addict special option resolved the problem. :frowning: I’m now looking for an Podcast app which can use an external player (like perhaps VLC?).

Finally, I can present a good always working workaround:
I consulted the developer of the app “Podcast Addict” and he was kind enough to implement the feature that you can see at ALL podcasts where your listening is currently in progress how far you already listened. So, you just have to look at that timestamp, click on play and in the case that the progress jumps you can go back to the real time manually.

Here is my suggestion and my procecdure to avoid the bug in detail and the developer’s answer:

Now at last we can enjoy podcasts on our Fairphones!! Yeah! :slight_smile: