Preferred network type - 2G/3G/4G auto

I’m new with Fairphone and I have a 3+. And it is not possible to use network type 4G. All incoming calls are transmitted anonymously, even if I have people stored in my contacts. When I change to 2G/3G auto it is not a problem. When will this problem solved?

Hi Erika,

there is already workaround for this.

Please go to Settings > Network and Internet > Mobile network > Advanced and deactivate the “Enhanced 4G LTE Mode”.

Good luck - and I guess that Fairphone will have an update in the forseeable future,

Best wishes,
Thomas

4 Likes