English

Power button and touchscreen do not work

I have a problem with my Fairphone 2. The Power Button and the touch of the display does not react anymore and I don’t know how to handle this. I didn’t find anything in the forum about this issue. I realised this, when the phone was on and decided to turn it off by removing the battery (maybe this wasn’t the most clever thing to do) and trying to restart the system what doesn’t work because the power button still does not work. Is there a possibility to do an hard reset via mac or something like that? Because I think this could be an software related issue mainly because it was the display AND the power button that suddenly weren’t reacting at the same time AND there was no physical harm to the phone. The phone battery is fully loaded and there is the loading screen and lights are on when I start charging the phone. Unfortunately I didn’t have the newest software update performed, because I wanted to backup my phone first…so if there is a possibility to do that with an external device that DOESN’T involve the power button maybe that would be enough to get the phone back on track. Is that possible?

Hey,
I’m sorry to see you haven’t received an answer so far.

Have you tried disassembling the phone to carefully clean in’s insides?

No I haven’t tried that. But my mobile phone is quite new and didn’t get dirty and especially because the touchscreen stopped working at the same moment as the power button I don’t think that this is a software problem.
But I will try that and hope it will work.
Thank you

Hey there, this support article might be useful for some of you with this touchscreen issue on your Fairphone 2, especially in order to remove the Display module and put it back.

https://fairphone.zendesk.com/hc/en-us/articles/211351686-My-display-screen-is-not-working-properly

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.