Poll + general discussion: who got Android 10 Update on their FP3 & first impressions

Worked for we as well. There are some minor bugs (using the new swipe navigation renders the search bar too close to the bottom row of apps for example), but generally I am happy about it. That’s why I will stick with the classic three button layout for so far. But I guess the engineers are already collecting feedback and trying to improve on these issues.

I can confirm the issue @mgkoeln has with the space between the carrier name and the current time.

Otherwise, it just works.


That link doesn’t seem to work anymore, but the new manual install link points to the new Q-3.A.0033 release (edit: I removed the direct link with the broken image) for FP3 and FP3+.

Edit: unzip -t gives: testing: system.img bad CRC 22cbcb73 (should be 5197923a)


Update went smoothly, “Smart Launcher” works well as before, so far all good.

@German_FP3_users: Does Vodafone provide the update yet? I left Vodafone bc of the update issues…

I answered the poll as no this morning, then this afternoon when I got the update through I changed my vote to say that it had been installed. The nice thing with the poll is that you can change your vote.

1 Like

I heard from three Vodafone customers today that they haven’t gotten the upgrade on their FP3s yet.

It seems like the square button for the app overview does not work anymore here after update. And with a long press the button changes visually to the multi-view button but also nothing happens.

I’m on 1&1 (which actually uses Vodafone infastructure) and haven’t got it either.

Another Vodafone victim here. I hope they get their act together before the new camera modules arrive…

But how can this depend on my phone provider? I’m here at home, connected to the internet by wifi. So my phone provider should make no difference… :thinking:

1 Like

On Vodafone UK. Still no update here…may have to go the manual way if they dont roll out before the cam modules arrive…

Is there no instruction to update manually from a Linux Computer? I found instructions for FP2, but this uses a script called flash-for-unix.sh which isn’t included in the FP3 update zip file.

Still no update :frowning:
From France with Bouygues provider.

When I went back from /e/ OS two weeks ago, the zip had the .sh script included. Do you want me to send it to you? I think it will be pretty much the same thing with different filenames.

For the ‘How’:
Fairphone switched to using Google’s update mechanism (the one baked into the settings menu). I recall that MCC/MNC values of the last primary SIM (usually the one that has/had a data connection) are sent as part of the request to check for updates. Android also has carrier services that allow dynamic configuration of the device by the carrier, I’m not sure whether this includes the ability to set an update channel or policy. In any case, the update is only pushed to a device if the carrier has approved it, or has supplied its own version.

For the ‘Why’:
This way carriers get the possibility to quality control updates and add carrier-specific features (like VoLTE/VoWiFi, but also bloatware). So one excuse is ‘user experience’, but I personally feel there are commercial reasons that better explain why this happens.

Showing up as ‘temporarily unavailable’ for me (here). That said, the Windows instructions link points to what appears to be an unreleased page (if @rae is collecting issues, please add this one).


Oh boy. This New date Bar is really annoying. Any solutions to get rid of IT?

1 Like

I’m on Vodafone too, but isn’t everyone being a tad dramatic? The rollout was supposed to be this week, right? Some providers sooner than others? It’s only been a day! As far as I know, the problem with Vodafone was fixed, so I’m just going to be patient and have faith :wink:

@Sideness Thanks for your kind offer, but this seems a little to dangerous to me. Things might (and probably will) have changed between the respective install processes, so I prefer to wait.

1 Like

@Johannes Thanks for this detailed information! This explains the procedure for smartphones sold by the carrier with carrier specific ROMs. But imho it makes no sense for “neutral” smartphones purchased independently from the carrier.
Anyway - if it’s just a delay of a few days, I’ll patiently wait.

I have installed Nova launcher for now. No date bar, no google search bar.


I can confirm - none of those issues with nova launcher. Using it for a long time already. And happy about.
With the update to Android 10 it strangely does not show the network connection (neither WiFi or mobile) anymore in the top right corner of the status bar. Anyone else experiencing the same issue?

Hm, something the zip file for the manual installation seems corrupt. I have the same sha256sum
as the download website mentions, so I think it’s downloaded correctly.
But when I extract this I get some zip errors when processing the system.img file.
Does this only happen to me?