Phone totally crashing many times a day after 1.8.1 update


I was out most of the day yesterday but not using my phone. When I got home the battery was flat so I put it on charge, thinking it was a bit weird as it had been fully charged over night and without Candy Crush or Pokemon it should’ve lasted!

When it came back, it had the “Updating app n of 167” screen so I assumed it had done an update. But then it kept trying to download 1.8.1 and freezing after a few percent. I downloaded it from my laptop, put it onto a MicroSD and then safe-mode installed it onto my FP2.

Now, it freezes many many times, rendering it useless as a phone. Seriously, it won’t last fifteen minutes without completely locking, no clock update, no scrolling text, no response to touch-screen. It also now has a four hour battery life. When it does work, no useful apps work - Facebook is dead, FB messenger crashes, SleepCycle doesn’t work. With the freezing issue I can’t use the default alarm clock either.

I have raised a support ticket but I wondered if I was alone, or if there was anything I could try?



Hi Grahamhm

I think i have the same problem. It happend this morning suddenly my phone froze (while getting very hot) and since than i keep rebooting . Dometimes i get a message that fairphone launcher 3 is not reacting with the option to close the app or wait. Neither choice has any positive result, it just freezes again for the next reboot. I think i also raise a ticket,


Yep, that’s exactly it. Also, Fairphone UI has stopped is another message too. Facebook has stopped seems to come up sometimes as well.



I think You should reinstall the Update 1.81 manually and clear the cache before. Erasing the cache was the solution for me in another case where the update failed.

Same here - phone locks up, goes black, randomly reboots. I tried reinstalling from SD card, but problem remains. Need support.

Cleared the cache before installing again?

Cleared cache of what? Everything has it’s own separate cache. Which should I clear?

If you hold down volume up and power for over 5 seconds you get a special menu, rather like going into safe mode in Windows. There is an option in there for clear cache, as well as install from SD Card.

Unfortunately I tried this and it didn’t make any difference!

Did You install an update or the whole system from SD-Card? I installed the complete system from the card and it worked well.

Same for me…
Do we have to wait for the next update then? Or did anyone get a solution from FP? I created a ticket as well.

Could you give me a link to the whole system download? I’m googling now and can only find the 1.8.1 update.


600mb OS version:
copy it to your SD card, hold the Vol-Up & Power button then update from the boot menu

So… I backed up my Fairphone2 thoroughly. I removed both SIMs and the SD Card. Then I did the system recovery menu (power button plus volume up for five seconds) and chose factory reset.

It took around six hours to download all my apps when I reconnected my Google account. After nearly 24 hours without a crash, I put in a SIM card, and have slowly re-introduced them.

So far, so good. Everything seems to work and it’s free from crashes. I think I had one “Facebook has stopped responding” but that was it.

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.