Phone recognising SIM but not connecting to network

Hello,

Super excited to receive my Fairphone today, and I think I’ve managed to follow all the instructions in setting it up.

I have installed my SIM card in the SIM 1 slot, and under SIM management the phone is recognising that the SIM is there, but it’s not picking up any signal, either for calls or data, and I’m getting an ‘emergency calls only’ message.

Has anyone else had the same problem? Have I missed something or should the phone/SIM talk to each other automatically?

Many thanks for any help!

Hannah

@HannahSals

Your phone should pick up your network automatically. Try going to Settings > choose More > select Mobile Operators > First try Choose Automatically to see if you can get registered on the network - if still doesn’t work try the Select Manually option and seeing if you can select your network

Also does the SIM work in another phone and if so have you tried it in SIM slot 2 to see if it picks it up there?

Hi Hannah,

Are you sure you entered the PIN code when you booted up the phone? If you get the emergency calls only message, you probably didn’t do this correctly.

Reboot your phone and try again. Or enable/disable Airplane mode, this way you can also enter the simcard pincode again.

Thanks both very much for your replies - I wasn’t asked for a SIM pincode when I turned it on but it turned out that the SIM hadn’t been activated. All up and running now so I can start enjoying my Fairphone! :slight_smile:

1 Like

Hi @HannahSals. Glad to hear you sorted that - and even better news that it wasn’t your phone.

Enjoy your new phone!!

This topic is now closed. New replies are no longer allowed