Phone not working after DIY repair


a few days ago I replaced the midframe (broken camera class) and the backward camera. After reassembling the phone it doesn’t work any more. The charge light is still shown correctly but the screen stays black and when I call the phone the connection seems open while the phone stays silent. Also the power button which I assigned to end calls doesn’t do anything.

I already handed in my issue to the zendesk on Friday but so far I didn’t get any reply. Did anybody else have a similar issue or an idea what I can do to fix this?


You should open your phone up again and check all connectors (especially the ones of the display, obviously). In the best case, there has only something gotten loose during your first repair attempt.

Already tried that. Multiple times. I didn’t find the issue.

The only explenation I have is that I broke of the little brown plastic piece of the “Digitizer ZIF plug” or that I put the cable in wrong (though I don’t know how else I could have put it back).

Can you make a picture of that? It it this one below the black sticker? Can you still ‘flip’ (ifixit picture link) the little brown bar on top of the connector? Can it be “shut”?

I think the most important connector to check (black screen) is this one.

Can you ‘talk’ to the phone using usb/adb?

I can’t “flip” the brown bar since it is broken of. But the sticker is still working and the cable seems to be connected correctly.

The phone is currently configured to only charge by default when connected via USB. So I would need the screen to change this.

It’s hard to tell. Especially if you cannot “talk” to the phone, so we do not know what state it is in. You said that you cannot “call” it, but I don’t know if you have any other problems during a “dark” boot process (rescue system, PIN …)

If it’s just the cable, I guess the phone should still work somehow even with a broken ZIF and that worries me a bit.

Have you tried switching on the phone “directly”? While it is still open by pressing the switch on the top directly for around ~6 secs? Normally this starts the normal boot sequence (as you know) after the battery was removed before … just in case something is wrong with the switch.

Nothing more comes to mind right know … Maybe someone else will also have another idea? Did you had any problems while replacing stuff?