Phone doesn't charge

My FP2 suddenly just doesn’t want to charge. Switched the battery, same problem. Tried an other charger still no solution. Both chargers are fairly new, a good quality and happily charges my wife’s phone.
If this is a hardware problem i guess there’s still some warranty, The phone is from oct. 2018
Anything else I can try?

Is your wife’s phone an FP2 as well? If yes, then you could try if the bottom module from her FP2 allows you to charge your FP2 if you “transplant” it.

No unfortunately not :frowning:

I already removed the battery. and fitted another one (with 75% instead of 3%.
The strange thing is that the screen say “charging” (in danish “oplader”) allthough no charging cable is fitted.
Google Photos

Writing to support I get this answer:
“We aim to reply within 10 business days.”
That makes me thinking of just buying a cheap Huawei-phone. :disappointed:

Removing the bottom module and inserting it again did the trick.
Never been taking the phone apart untill now. A bit scary but it worked.


I had the same problem around year ago. Unfortunately, I didnt bother to take the phone apart. I was too scared. I eventually bought a replacement. But its a good thing you were able to fix yours.

What happened to the old phone then?

This morning the “no charging problem” was back. I removed the bottom module and reinstalled it. This time it didn’t solve the problem :frowning:
I bought the phone January 16’th 2019. This ought to be a warranty issue…?

Yes, if you bought it directly from Fairphone, then I suggest you open a ticket.
Go to support and follow the steps at ‘Something else’.


This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.