Phantom Mobil Data Packets

Today I realised that my FP2 with OpenOS (7.1.2 / 19.08.1) sends and/or receives tiny data packets (mostly 1-2 kB) about 2-5 times per day.

This really shouldn’t be the case because I always have all forms of data (wifi, bluetooth, mobile data, data roaming and even GPS) turned OFF at all times, unless I actively want to use them (which happens very rarely - no social media etc, typically all data via laptop independently of my phone).

The problem: while recently overseas, these tiny packets doubled my phone bill even though I didn’t actually use any data and was sure that all data was turned off while away.

Has anyone else noticed this behaviour?

Is there a reliable way to keep the phone quiet without using airplane mode (which also kills the voice and sms features - which is what I actually use my phone for :slight_smile: )



Stupid question: Did you have data roaming active or not?

MMS enabled in SIM settings?

1 Like

Hi Teezeh & JeroenH,

data roaming is off but MMS is configured (see below), however, there is no button to turn MMS on/off. I also only use MMS 1-2 times per year to receive MMS e.g. birthday greetings (knowingly at least… unknowingly? who knows?).

Also, the fact that 1-2 kB are sent/received 2-5 times a day doesn’t match my activity - there’s nothing I do on the phone that often.

The worst thing is that I won’t find out if any changes have any effect until the next bill arrives… once a month :frowning:

Here are my settings… as mentioned before, always off unless I actually want to access data:

  • Settings:
    • Wireless & networks:
      • Wi-Fi: Disabled
      • Bluetooth: Disabled
      • SIM cards: (just 1, no preferences available)
      • Data usage: 0%
        • Data Saver: Disabled/unconfigured (shouldn’t be necessary when mobile data is off anyway, right ?!?)
        • Mobile Data: Disabled
          0 B used between 1 - 31 Dec.
      • Aeroplane mode: Disabled (I do want calls and SMS to get through)
      • Tethering & portable hotspot: Disabled
      • Mobile networks:
        • Data roaming: Disabled
        • Preferred Network type: 4G
        • APN:
          MMS is configured but almost never used
          Protocol: IPv4/IPv6
          Roaming Protocol: IPv4/IPv6
        • Network operators: Choose automatically
1 Like

Where do you see this activity? In the phone or only on the bill?


Try and see if it still happens when you remove the configuration. Although it is odd that it even works without roaming and without data on, what happens with MMS is it just makes a connection to a sortof proxy ran by the provider which contains a HTTP server with all the pictures/videos which are send.

Other than that, I don’t know, except that these are software killswitches. They may not work well. If you put a firewall on your computer (say, NetGuard) you can make some pcaps but we don’t know which interface is being used, do we?

Perhaps it occurred during a reboot, before the software killswitches were active? Does anyone know if that is how Android works?

A logical explanation I can think of is an implant, but it is easy to make such statement without backing it up. It’d require an extensive investigation ie. proof.

Hi Buncer,
I experienced the same problem last August / September during my stay in Ukraine. As a quick solution I removed my simcard cause I didn’t need the phone - internet was enough for me. But that’s not what you want.
Later my son made the phone to do these data packets only when in (free) wlan - not in any other “tacted” (“counted”?) connections. Haven’t been abroad since then to test it. (And I don’t know how he did it, sorry)
Threema keeps complaining about the background activities being cut off, but as soon as there’s wlan, Threema shows all the new messages.
Phone calls are possible. SMS - I can’t tell, because I almost never get any.

I think metered is the word you are looking for.

This sounds like data was simply not disabled, which your son did for you later & the OP already did.

Hi Everyone,

thanks for the tips.

I only see the activity on the bill - the phone itself reports 0 B (see my second post).
Nefarious implants? I hope not! (my loving dearest also has the same problem on her non-fairphone - according to various forums it’s a well known misbehaviour common to android and iOS, but it seems to depend on other circumstances as well, i.e.: your carrier - but if the phone says it’s not using mobile data, it should definitely NOT use mobile data, regardless of carrier!)

MMS is indeed weird. I still have it configured because occasionally I’ll get one - then I have to turn on mobile data or wifi to actually see what was sent. I then turn off data again. (The MMS notification itself seems to arrive via SMS but the data requires wifi or mobile data to get through)
To have to also configure MMS on the 2-3 occasions per year when I get one is getting a bit much. Maybe I can train my people to avoid MMS?

Anyway, I’ve now turned on “data saver” and will see what’s on the next bill.
Also, today Fairphone released (or… my phone detected…) Open OS 19.11.2 - so I’ve updated which may have an effect.
If all that doesn’t work I’ll deconfigure MMS and continue watching.

Thanks for the responses!



For me, the bill and usage on the phone itself usually match quite well. I suspect an issue with your operator if it’s not MMS.

With MMS you receive a SMS which is then remotely fetched from a proxy. This is regularly a LAN proxy which can only be accessed from within the mobile network. The pictures are also often downsized and compressed, and get removed after X days from the proxy.

(In 2015 there was a vulnerability within the multimedia component of Android, called Stagefright, which allowed remote root access.)

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.