English

Phantom major battery drain on FPOS 17.10.2 FP2

Hello,

Over the past few days I have been experiencing a major problem with my Fairphone 2 running Open OS 17.10.2.

Even when my phone is directly plugged into an AC power source with no apps running (I specifically tried exiting all apps), the battery (starting from 100% full) drains super quickly in a few hours!! I can literally see the battery percentage tick down every few seconds!

Here is a screenshot of the battery screen just before the phone turned itself off (while plugged into a power source):

You can also see that “Miscellaneous” is the major power drainer, but I have no idea what that means???

In order to recharge my phone I have to turn it off first, because even when it is on the battery drains while plugged in!

This is making my phone unusable, since if I unplug it I might only get 30-minutes worth of battery life with no apps running.

I saw this thread but it doesn’t seem to have a solution.

How do I troubleshoot this??? Thank you.

1 Like

What’s the microphone on for? (symbol in the top bar)

2 Likes

The microphone icon is for the Audio Recorder app I installed from F-droid. It’s actually not running, but if I swipe down from the top it shows me a button I can click on to start a recording.

This app has been around for a couple months, so I don’t think it’s related to my current predicament.

Anything else I can try to fix this?

2 Likes

Sure, you don’t have a virus running? In your screenshot you have Wifi turned on. How long does your phone last in flight mode and Wifi off?

2 Likes

Try installing Better Battery Stats to see if there is some process which avoids your cpu to go in idle mode

4 Likes

Maybe you got a bad app?

https://blog.fefe.de/?ts=a70a980a

People are tageting App-Makers with high number of dowloads to put in updates for mining on smartphones… :wink:

4 Likes

Sorry for my slow response, thanks everyone for your suggestions.

@Amber: In the screenshot my wifi was on. But I’ve tried airplane mode and the battery still dies super fast as I described… :frowning: Is there any way to check for viruses??

@DjDas: Thanks for suggesting Better Battery Stats, I’m happy to give it a try. But before I do: Is there a recommended F-droid app that I could use instead? (I try to avoid Google like the plague)

@Drezil: Wow, I didn’t know about this whole mining thing going on. Is there a list of bad apps that I can check for? That said, I didn’t install new apps close to when the problem started so I’m not sure if a secretly-mining-app is the problem? On the other hand, maybe the bad app didn’t start mining until I started experiencing the problem?

1 Like

There is anti virus software on Google Play and some are even working some times, but I think it is better to look up for battery drainers like with some battery app checkers (Better Battery Stats :wink: Is it not available on F-Droid? I thought so.

Even with a regular Google-enabled, non-rooted device a bad app it can hide itself, so it is very hard to detect. But we don’t want to assume the worst…

If you have not Google Play Store installed and avoid Google Play Software but practically use only F-Droid software then the risk of having a Virus is probably low. But maybe there is simply a Software which does not work as expected by the developer and drains particularly FP2s?

Nope. Not available on F-Droid.
And it requires root from Android 4.4 upward; unless you are tech-savvy. :wink:
From the playstore:

That’s why I don’t run it. :frowning:

[quote=“Amber, post:8, topic:34592”]
But maybe there is simply a Software which does not work as expected by the developer and drains particularly FP2s?[/quote]
I wish I would know, what app that is.
Sometimes my FP2 gets really hot as well and only turning it off and taking out the battery for a few minutes helps. I put that on some process running as well. Just have not figured out which one is to blame; unfortunately.

2 Likes

You could try the developer-tools to get info (settings-> about phone ->hit "build number 7 times; then go to settings -> developer-tools (should appear now) -> current services).

There should be a list of all running services. You could try killing off services and see if the drain wears off.
Somewhere in the dev-tools there should be a “top”-application that draws itself on top of everything so you can see which processes take up much CPU-Time (thus draining the battery).

All this should work without root.

2 Likes

Thx a lot for those tips.
Already had the developer options activated, but did not work out those possibilities.
Now I have the overlay activated, that shows (top right corner) the CPU usage. Looks cool ;), although I hardly know what it tells me in detail:
Besides the active processes (that’s what I need to know), there are three changing numbers and in the background a changing red/green column (I guess that’s a visualization of the usage; something I not really need to know).

Please continue here: