English

✏ µG Unified Nlp (with Installation Guide)

Yes thats all I did. I didn’t rename the App and didn’t download the Version from F-Droid.
The backends I use are:

  • GSM location B.
  • Personal Wifi B.
  • GSMNetworkLocationProvider
  • Ichnea B.

although atleast the Ichnea Backend is redundant.
maybe you used another backend and that one drained your battery?

oh and one more thing but i explained that before and i think i’m the only one who didn’t automatically do it: you have to turn on wifi&network location access in system settings.

Yes, I’m sure it was LocalWifiNlpBackend because I was able to log the battery drain since its installation and until its removing.
I’ll try your configuration :smile:
Thanks!

When I launch µg unifiedNlp and click on “configure location backends”, the application crashes.
¿Is it normal?
Wifi&network location is enabled (although the description of the option mentions google :confused: )
I installed all the backends I could find, and OSMand doesn’t find my position. I live in a big city in Spain.
Something must be going wrong :frowning:

no that is not normal. my guess: something went wrong with the installation of either one of your backends or the unified backend. you could try uninstalling all backends, see if it still crashes, then reinstall the backends one by one to see wich one causes the crash. if uninstalling the backends doesn’t work you could try uninstalling and reinstalling the unified backend. maybe test it before you make it a system app as well; it shouldn’t work as a user app, but it shouldn’t crash either.

I ran into the same trouble and did a quick research, until I found this. adbd Insecure 2.00 did the trick for me. The error message from adb doesn’t come up anymore and everything works as expected.

1 Like

It’s the only backend I am using, and I also started stumbling around with Mozilla Stumbler. :smiley:

A lot of blank areas still, where I live, but I’ll map it all. :wink:

1 Like

I’m allready in the top 1000 stumblers worldwide :smiley:
tomorrow I’ll stumble over to swizzerland while helping my brother move there

2 Likes

Congratulations, Paul! :smiley:

1 Like

GREAT! :smile:
Keep up with the good work! :smile:

Thanks to @Stefan tip, I think I managed to install unifiedNlp with the technique described in https://github.com/microg/android_packages_apps_UnifiedNlp
I say “I think” because I haven’t had any error doing the adb thing, but the app doesn’t show in my app list. So I can’t enter th app to manage the backends.
OSMand doesn’t find me on the map. I don’t know if it is because my city (Donostia San Sebastian in Spain) is a backend desert or because µg unfiednlp doesn’t work.

Question for people who manage to use µg unifiednlp on a GAPPS-free Fairphone: ¿Does the application show?

Yes it does:

1 Like

Gosh. I don’t have that :frowning:
Did you follow exactly these instructions with these command lines?

1 Download LegacyNetworkLocation.apk
2 Mount /system read-write (from your PC, call adb root && adb remount)
3 Copy LegacyNetworkLocation.apk to /system/app (from ypur PC, call adb push LegacyNetworkLocation.apk /system/priv-app/NetworkLocation.apk)
4 Reboot (from you PC, call adb reboot)

Yes, did you do, what I did (as explained in post #30)?

Yes I did what you mentioned in your post.
Finally I got it work :slight_smile:
Instead of writing “adb push LegacyNetworkLocation.apk /system/priv-app/NetworkLocation.apk” i did “adb push LegacyNetworkLocation.apk /system/app/LegacyNetworkLocation.apk” and the app appeared ! :sunny:

Yes, now I remember, I had to change priv-app to app because Android 4.2.2 doesn’t have the directory priv-app. :slight_smile:

Edit: I updated my original post and made it a wiki post for everyone to contribute.

Exactly this setup worked for me; albeit I have chosen another installation method:

  • download LegacyNetworkLocation.apk
  • adb install LegacyNetworkLocation.apk
  • use TitaniumBackup to make it system app ; reboot
  • install backends . Reboot. Now I can have a location bubble in osmand without GPS signal. Fine.
2 Likes

Good news: The legacy version of µg Unified Nlp is now available from F-Droid. This makes installation easier.

2 Likes

Easier how? Is it not necessary to make it a system app anymore? On F-Droid’s App description it sounds like it’s used as a user app, but it also says it’s for AOSP devices.

Yes, for me it works without making it a system app.

3 Likes