Outlook.com exchange active sync not working

Hi everyone

All my contacts and calendar infos are stored in my outlook.com exchange active sync account.
Under Android 5, syncing these to my Fairphone worked fine, by adding an “Exchange” account in the accounts settings.

When I now do the same in Android 6, only the e-mails get synced. After setup, my outlook-account shows up as an IMAP account in the accounts list - this explains why only the mails are synced. I currently cannot access my contacts or calendar.

While I wrote this, I took one last try and came to the solution. I’m posting this in case someone has the same problem:

  • Choose “Exchange” from the add account menu
  • enter your mail address
  • DO NOT tap on “continue” (for me, this always adds an IMAP account, instead of the exchange account)
  • instead scroll down to the option “manual setup” and tap that, enter the following:
  • Server: outlook.office365.com
  • Port: 443
  • Security: SSL/TLS



Please update to 17.04.8, the AOSP e-mail app and the Exchange app are back.