OS Updater App offers update to old version

Hey Guys,

I use FP Open OS and my updater App (currently version 1.39.9) has never really worked (did a manual update last time), so I thought I might try to get it fixed now, finally.

My current OS version is 17.09.3, which the app shows correctly. But it only offers me to update to 17.06.4. (which makes no sense, of course). According to code.fairphoe.com the newest available version is 17.11.2

Now, I checked my firewall (which I have set up very restrictively), AFWall+, but the app has all permissions. Then I checked the Android App Permissions: It requires “Storage” and “Telephone”, which both are fully granted.

Do you have any other ideas, what the cause could be?

Many Thanks in advance!


Just checked on my FP2 FP OS 17.11.2): Updater app version is also 1.39.9, so the app version itself seems to be ok.
Does it help if you delete the app’s cache and data?

Thanks for your fast reply.

After deleting the app’s cache and data, the app states that my OS were up to date (which it is not). I still have version 17.09.3 installed. I also restarted the phone after deletion.

I don’t know whether this hint is of any help, but my firewall tells me that the following system apps are trying to access the internet (which is currently restricted):

  • Media Storage(10007)
  • PPPreferences(1000)
  • (kernel) - Linux kernel

Do any of you know, whether any of these component are relevant in this case? I haven’t had any problems with other apps so far, so I would like to keep internet access as restrictive as possible.

All the best,


Well obviously you need to give the updater internet permission. And it needs internet via wifi to work properly.

Thanks, yes the Faiphone Updater has full permissions to access wifi and cell internet. (in my firewall) Wifi is currently active (cell internet deactivated). My internet browser, for example, is working perfectly.

Another interesting thing: AFWall+ usually shows all apps that want internet access in white, while those apps not requesting for internet access are green. Fairphone Updater is green!

Check out the app permissions in Settings > Apps. If the updater doesn’t have the permission to access internet that would explain why it’s green in afwall+.
Do you have any other apps that might interfere with the updater’s access to internet?

Updater explicitly only asks for “Storage” and “Telephone” permissions. Both are granted. When I choose “all permissions” and tap on “full network access” Android gives me the following note:

“Allows the app to create network sockets and use customised network protocols. The browser and other applications provide means to send data to the internet, so this permission is not required to send data to the internet.”

Among the extended permissions there is also "download files without notification, which gives me the following note, when I tap on it:

“Allows the application to download files through the download manager without any notification being shown to the user”

Is that of any help to you?

The only other thing I can think of is trying to boot into #dic:safemode and see if the updater app works there. If so there is some 3rd party app that interferes.

Are you sure these are reported correctly? At least on older versions of Android, system apps shared the same ID, and most firewalls log the ID and assign a programme name to it afterwards. The firewall on my FP1 is unable to distinguish between:

  • Media Storage, DRM protected content storage and Download Manager
  • ID 1000: Android System, Key Chain, Settings Storage, com.android.provision, Settings, … [list goes on]

If your firewall also reports to which server these apps were trying to connect, look for the fairphone domain (or googleapis, see below) - this may also tell you which one is relevant.

Another potential issue is that Fairphone updates are stored on google domains (notably googleapis.com). In case you’ve blocked or redirected requests to google domains (or have an app that does that), that could also be the issue.

1 Like

Hey Guys, many thanks, that gives me some food for thought!

I will sit down to look at the whole thing in about a week or so (really busy now) and let you know about the results.

All the best,


Hey Guys,

sorry for the long absence. I finally go around to trying the things out.

First of all I tried out safe mode: Fairphone Updater worked perfectly there, so I did my update. (Thanks @paulakreuzer )

Still, I am not quite happy with the result, because it is important to me, not to let the phone do anything on the internet without an active firewall. In safe mode at least third party apps may not be sending anything out via the internet, but I am also quite careful about other backdoors that are elsewhere in the system (despite not having GoogleApps on my system).

My guess is, that it has something to do with the firewall (AFWall+), as AnotherElk mentioned.

@Johannes thanks for the hint. Unfortunately my firewall does not enable me to check the servers (or in no way that I know how to access). Can you tell me how or is it rather complicated and only suitable for real geeks? :slight_smile:

All the best,


I just remembered (and found) a post:

It seems AFWall and the Updater don’t agree with each other.
So you can either shut down AFWall once a month to perform the update via the updater or switch to updating manually.

1 Like

Thanx, Paula! I guess I’ll have to go back to updating manually then, in the future…

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.