OpenTracks not getting GPS fix, even though GPStest shows 20/23/31 satellites

Hi, sorry if this is not in the right section. I have no idea if my problem is OS or app related, so I thought to ask it on this forum also.

I just installed OpenTracks on my Fairphone 4 running iodéOS, and have my Motorola g31 (with Android) right beside it, also with OpenTracks (GPStest and SatStat installed on both devices)

Both FP4 and Moto g31 show the same amount of satellites in GPStest : 20/23/31, with the FP4 showing better D/R0 (signal strength), but as mentioned in the title, OpenTracks on the FP4 (with iodéOS) continuously keeps switching between ‘Waiting for better GPS signal’ and ‘GPS disabled’, without ever getting a GPS fix.

My Moto g31 actually gets a GPS fix almost instantly, despite having weaker signals all around.

Anybody have any idea on where this goes wrong? In the iodéOS ? MicroG maybe ? Bug in the OpenTrack app ?

1 Like

What permission did you grant the OpenTracks Apps to GPS, always or only when the App is used? Is it the same on the other device? Is the other device also running without GApps? What about other Apps like MagicEarth?

Sitting at my Kirchen table Open Tracks on FP3 with Iode 3.1 seem to work, can check what happens when I’m moving later.

1 Like

‘Allow only when using the app’ on both phones (that is the only option available, besides ‘Ask every time’ and ‘Don’t allow’).

The Moto g31 is running (almost) stock Android.

Apps like OSMand and MagicEarth work instantly and accurately.

So for me on the FP3 it takes around 1-2 Minutes to find GPS after that it seems to work, however often its the same with MagicEarth on my FP3 (also with FPOS). I never really used OpenTracks as I do not really get what to do with the App, as at the end to visualize the track I need another App (or I misunderstand something) so somehow useless for my use case.

So my guess would be its the Kombination of MicroG and the App, as other Apps work and the App works on a phone with Google Apps.

In the settings under location, do you have at least the BT function enabled or even also Wifi?

What happens if you actually record a track? :thinking:

I have a pulsating GPS icon and a notification telling me something similar to

on both a FP4 running stock FPOS (A11) and one running CalyxOS (A12), but once I hit record everything works and both produce a accurate track when I take them for a short walk.
It seems to work with GMS and microG, so it should work on iode as well :man_shrugging:

Oh and welcome to the community :wave:

1 Like

It keeps flashing a message that GPS is disabled. It records altitude and elapsed time, but nothing else. Really weird it gives me altitude though.

Huh, weird :thinking:
Have you tried Inject PSDS data and Inject time date in GPSTest followed by a reboot?

Strange that it shows altitude, but that is often based on the barometer I believe, so probably doesn’t tell us much about the GPS problem.
But the barometer probably would rely on GPS data to auto-calibrate as well…

This very much still feels like a problem with permissions, have you tried deactivating battery optimizations for OpenTracks?
Is microG set up properly (including the NLP backends)?

Also note that there is an iode specific forum:

No, because I have no idea what that is. I’m new to degoogled androis OS. Can you give a short explanation on what I should do, or a link to a tutorial ?

Open the microG app, select Self-Check and look for missing checkmarks :white_check_mark: first.
Afterwards check if you have backends in Location modules enabled.
You should also check if you disabled connectivity for the backends listed there in your firewall app (no idea how that’s named on iode).

You don’t necessarily need a working microG setup to use GPS / location based apps, but depending on the app this can drastically reduce the time needed to get a first fix.

Did you try any of the other suggestions, like injecting PSDS data?

Well he did ask there as well it seems, but apparently their forum isn’t all that active… :man_shrugging:


iodéOS has its own version of microG apparently, with no UI. I can see however that backends for UnifiedNLP like ‘Apple UnifiedNlp Backend’ are included.

I also tried to install UnifiedNLP (GAPPS), but it kept stating that it couldn’t ‘bind’ to the OS. I presume because iodéOS allready has a version of UnifiedNLP running that ‘allready has that bind’.

I still have my old stock Android phone, and I just wanted to use OpenTracks to replace my Strava biking app, that won’t run without Google Location Service, but eventually I want to make the full switch to degoogled. I wanted to install LineagoOS on my FP4, but since it is still in beta, and I’ve never forgotten that I bricked my Volla Phone six days after buying it, I’m a little hesitant to try switching to another OS, because atm my knowledge on Android or custom ROMs is practically non existant. Kinda dangerous with a +600-Euro-phone :stuck_out_tongue:

If there’s no microG “app”, you can usually find it under Settings → System → microG Settings.
I’ve never used iodé but I don’t think they are shipping without any way to control microG… (if you didn’t opt to remove microG during the first boot setup)

Yeah, don’t install that. You should only install additional NLP providers / backends on systems with microG (which includes UnifiedNLP) already installed.
You can install the MozillaNlpBackend for example if you don’t have it installed or want to switch from the Apple one. They all have their own strengths and weaknesses.

1 Like

Oh ! Thank you for that ! I didn’t know. There is a section in there called ‘Location modules’ and ‘Apple Wifi’ and ‘ Unfied NLP’ were not turned on. After I did OpenTracks switched to ‘GPS fixed and ready’.

Problem Solved !!! Thank you !!!

Gonna try that MozillaNlpBbackend now.


Ow, that is allready active.

Maybe it didn’t have Internet permissions :thinking:

Regardless, if it works with the other backends just use those.
I use the Mozilla backend mostly because I’m also using TowerCollector to map the cell towers in my region and that way I can directly benefit from my own work :smirk:
But as I said, if the ones you activated work fine don’t change anything :slightly_smiling_face:

Go to system / apps/ all apps / show system apps and check that all NLPs has access to location “ever” not only “at usage”

1 Like

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.