English

Open Camera, the new FP2 camera and the annoying "Bling!" shutter sound when taking videos

Hellow fellow forumlings

Disclaimer: This post is about taking VIDEOS. Not about photos.

Screenshot_20200413-192524

Since I use Open Camera, the FP2 new Camera is at least useable. Thanks to @rmf for the tip back in 2018. Pointing and shooting still takes up to 5 seconds, but hey, I am happy that it works at all.

Now when I take videos I always get the “Bling!” shutter sound at the beginning. Of course, this “Bling!” shutter sound gets recorded first thing in the video. So after having taken some videos, I transfer them with MTP (yawn!) to my Windows PC.
Then I have to sit down and cut the first second out of every single video because they all start with the annoying “Bling!” shutter sound. I guess I could make a compilation with the first second of every video I took for a year and it would go BLING! BLING! BLING! BLING! BLING! …

I checked with the Open Camera forum and found out that this can be be disabled in the app’s settings if the camera supports the Camera2 API. If the setting is not there, the camera does not support it. I do not have that option in my app, so I determined that the FP2 new camera has no support for Camera2 API, at least not the level that’s required to shut off the annoying “Bling!” shutter sound when taking videos.

Soooo… anyone here who uses their FP2 with the new camera and the Open Camera app?

  • Do you have the same issue?
  • Did you resolve it and if so, how? I am open to alternative app suggestions as well. I have a brwoser and the F-Droid app.

I can’t confirm this. When I record a video, the video shutter sound doesn’t get recorded.
I can confirm there’s seemingly no option to turn it off, though. There is an option to turn off the shutter sound, but it only applies to the photo shutter sound.

(Open Camera v1.47.3, LineageOS for microG 20200317)

I’m on FPOpen 19.11.2 using OpenCamera, and I don’t hear any kind of sound at all. In fact, when I enable the shutter sound for photos, I hear nothing, probably owing to the fact that I removed all audio files from /system/audio and replaced them with some sound files of my own.

So that’s worth a try: remove the shutter sound file from /system/audio/ - one of the subfolders there, I’m not sure which one.

Edit: I’ll wager it’s /system/media/audio/ui/VideoRecord.ogg and possibly /system/media/audio/ui/VideoStop.ogg.

1 Like

Thanks. Unfortunately I cant do anything with the ogg file since /system apparently is write protected. Now googling for ways to un-write-protect /system

I use GhostCommander and have root privilegies

If you hook up the phone to your PC with USB debugging turned on, with ‘Root access’ set to ‘apps and ADB’ in the Developer Settings, and then use ADB, it’s these commands:

adb shell mv /system/media/audio/ui/VideoRecord.ogg /system/media/audio/ui/VideoRecord.ogg.bak
adb shell mv /system/media/audio/ui/VideoStop.ogg /system/media/audio/ui/VideoStop.ogg.bak

That renames the files to .bak so if it does break something (can’t see how it would) or if it doesn’t work, they’re easily renamed back.

2 Likes

Interesting phenomenon. Yes, I have the same issue, but no problem so far because I don’t take videos usually. I incidently found out, that the sound doesn’t play when the phone is in do-not-disturb mode.

1 Like

Thanks all for your replies. My problem is solved.
So, to recap:

Main Problem: Open Camera goes “Bling!” every time I start recording a video. “Bling!” gets recorded every time. This is very annoying.

Solution 1: Disable “Bling!” in Open Camera settings
Failed: The new and improved 12MP Fairphone Camera™ does not support Camera2API, therefore disabling “Bling!” in Open Carmea settings is impossible (among a plethora of other functionality as I found out).

Solution 2 from the awesome fellow forumlings: Delete “Bling!” sound file from the phone
Sub-Problem: Cannot change anything in /system because this filesystem is mounted write-only (only look! no touch!)
Sub-Solution: Re-Mount /system, then delete/rename sound file

ere’s the compiled solution:
How to disable your Fairphone 2 shutter sound in just a few easy steps

  1. download and install/copy SDK Platform Tools for your computer’s OS
  2. open a command prompt in the folder, where the SDK Platform Tools are
  3. in your Fairphone’s developer settings, set Root Access to Apps and ADB
  4. in the same menu turn on USB-Debugging
  5. connect Fairphone to your computer by means of a USB cable
  6. back to your computer, in the terminal opened at point no. 2, type adb and press enter
  7. your Fairphone now asks you for permission to give permission to your computer to execute commands via adb. Allow it. Permanently.
  8. back to your computer, in the terminal, type adb root and press enter
  9. then type adb remount and press enter. <- Sub-Problem solved!
  10. then type adb shell mv /system/media/audio/ui/VideoRecord.ogg /system/media/audio/ui/VideoRecord.ogg.bak and hit enter <- Main problem solved
  11. then type adb shell mv /system/media/audio/ui/VideoRecord.ogg /system/media/audio/ui/VideoStop.ogg.bak and hit enter <- another problem prevented

I hope I am the only one having this exact problem. If a standard user has to jump all these hoops to stop their phone going “Bling!” when recording a video, I don’t know man…

PS: My flatmate is reading all of this as I am writing it and goes “Solution 3: JUST BUY A NEW PHONE ALREADY!”

Nah… I bled
CHF 599.00 for it back in July 2017.
CHF 103.90 for a replacement Battery and Camera Module in Sept. 2018
CHF 38.90 for a replacement bottom module Nov. 2018

The longer I can keep using it without having to invest more money into it, I will keep it, despite reboots during calls, stuttery audio reproduction, WiFi problems and and and…

THAAAANK YOU ALL!

3 Likes
  1. You are now a hacker

Also I think you mean VideoStop.ogg in step 11.

2 Likes

Fixed, thanks!

If I was a hacker, I’d hack into Fairphone to see what they are really up to. #tinfoilhat :slight_smile:

If I was a hacker, I’d make my own OS.
With blackjack.
And hookers.
#bender

1 Like

Just in case this becomes an issue later: this approach may cause incremental system updates to fail. If it does, you can install the full update package manually. The approach to disable the shutter sound will then need to be performed again (or look into writing a addon.d file with appropriate commands if using community TWRP).

2 Likes

Thank you for your considerate reply. If you check my history, you will see that to most of my problems, there is a solution. But there always is some kind of tradeoff. So with the Fairphone, I’ve gotten used to it. I am happy with however I can ease the pain.

I am using TWRP. It’s the one from the TWRP website. I don’t know if that’s the community version.

I did a quick Quack on addon.d, but couldn’t find anything detailing what it is and how to create/handle it. Do you have a link?

The stack exchange question linked below has an answer that provides a reasonable introduction, as far as I can tell (as I’ve never tried this myself). I know the question mentions removing apps, but what you’re aiming to do should also be possible. It won’t remove the need to manually install full updates, but you can set it up to automatically disable the shutter sound after you do the manual install.

1 Like

The preview looks promising. Thank you!

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.