Oooh. Ohhh. Lineage 15.1 (testing)

Oops, I’m using Nova Launcher, forgot about that :stuck_out_tongue:

Not sure that Trebuchet for 15.1 allows that. Probably have to use a custom launcher…

I’ve so far not had any dual SIM problems. I do not have a pin assigned to either SIM though.

Interestingly there seems to be similar trouble over at Fairphone’s Android 7 beta when LinageOS based on Android 7 never had this … maybe it’s the same problem and Fairphone will do the necessary homework at least for their TWRP build … I’ll take anything that works :slight_smile: .

At current state, I’ll have to provide self compiled twrp. I’ll post back here when it’s available. Until then keep reporting bugs :slight_smile:


1 Like

Found this in the German LineageOS Forum. It seems not only Fairphones have a problem with TWRP and Lineage 15.1.


Could someone please test all available bluetooth devices including ant+ stuff that I don’t own?


I failed to send apks via Bluetooth from my FP1 with Macadamia to the FP2 with LOS 15.1.

I don’t have many BT devices, so my tests are short :wink:

  • MusicMan BT-X2 speakers
    • playback works fine
    • it’s a rather old and low-price speaker and I can’t even find specs online, so I can’t give more details
  • Lenovo Thinkpad P50 with Windows 10
    • file transfer from laptop to FP2 works
    • sending files from FP2 to laptop does nothing (never used this before; win 10 says there should be some kind of notification if a BT device wants to send a file, but there is no notification)

I have been using the my FP with the 15.1 build and the Aftershokz Trekz Titanium Bluetooth earphones.
Pairing works well, connection works and playback (with Spotify) does also work, but the playback stops irregular after about 15-20 minutes. I have to wait for a few seconds and press the play button on the headphones again and the playback continues (but stops again afters some time).

I’ve used in my car, no difference in performance either with phone calls or playing media. I had the problems described by @Pitey with 14.1 but not played media long enough yet to know if it continues as described for me

Right, I forgot that, I had the problem als with 14.1 but definitely much less.
I have a commute of about 45 minutes, with 14.1 it stopped maybe once in 2-3 days. Now (with 15.1) as described every 15-20 minutes.
I suspected Spotify as the problem and added it to the “Not optimized” apps in the battery settings, but the problems remains.


What is a normal value for cell standby in the battery statistics? My battery is at 70% right now and 17% are used for cell standby.

Build installed via TWRP 3.2.2-0 (Releases)

The following things work for me so far:

  • call / be called
  • send SMS / receive SMS
  • internet via WiFi
  • internet via mobile network
  • location
  • compass
  • screenshot
  • main camera (new module, flash works correctly with Open Camera)
  • selfie camera (new module)
  • USB connection to PC / MTP
  • alarm
  • MyPhoneExplorer 1.8.9
  • root (Settings - Developer Settings - Root Access)
  • WiFi hotspot
  • Bluetooth (music playback, data connection)
  • FM radio

Ok, I’m counting on you, this is my daily driver for now :slight_smile:

Strict confirmed.

No issues for me with this build.

Doesn’t work for me, step 1/3 seems to hang forever supposedly fetching data from the sensor.

I checked Kernel Adiutor with the “Apps and ADB” setting … works as intended. Asks for root and works when granted.

Can’t confirm this with this build. Which website was it?

I thought I had this, too … but then I activated more repositories and this was gone, F-Droid was showing the installed Apps correctly then.

I’m more with @Stefan here. The stock file manager doesn’t install APKs from Internal Storage and it doesn’t ask for permission to do so … but it does install APKs without a problem from SD card.


Doesn’t work for me. Do I need to enable this first somewhere I didn’t see it?

Confirmed, doesn’t work for me, too. Reboots into LineageOS.
New camera modules … but then it was working in LineageOS 14.1 with them.

I also don’t have such devices.


So…finally!!! Almost everything works. I can confirm the following:

  1. The latest build works perfectly with Xposed.
  2. Bluetooth works pretty good for me, including data transfer to and from a mac.
  3. Root works perfectly by activating it in the developer options.
  4. I have not encrypted the FP2 for the time being untl TWRP can handle encryption on Lineage OS 15.1.
  5. Location services do not work as Unifiednlp is not integrated in the system. Roboe’s zip files do not work on Oreo (as mentioned by him).

Update: Proximity calibration tool does not work. I can confirm that. It gets stuck in Step 1/3.


i have tested ant+ and with the garmin watch and scale it works perfectly.


Hello !
Reboot into recovery doesn’t work for me, too.
Initially, only simple Reboot button is there, one has to activate “Advanced reboot” in “Developper settings” to display the 3 options.

Android “Trust” complains that this version is signed with public keys. Is that normal and inherent to the fact that it’s an unofficial test build? I assume this message will disappear once we’ll migrate to official LineageOS, right ? :slight_smile:
Note that this notification can be avoided in Settings > Security and Confidentiality > Trust > Version signature

1 Like

hey, quick question, i read that a download issue is fixed, the thing with owncloud works now? :smiley:

Yes, owncloud works for me as expected.

1 Like

I installed on Sunday, no problems until today.
For some reasons I wanted to deactivate SIM1, which SEEMED to work, it wasn’t shown in the status bar any more. Nonetheless WAS it working. I recognized this, when someone was calling me on SIM1, which should not have worked at that time. So when I deactivate SIM1, it just looks like it is offline, but it is working in the background.

And: LTE on SIM2 was only working after telling SIM1 to use G2 (didn’t try G3), I knew this was the case in some earlier Open FPOS version, but then you could only chose LTE for one of the SIMs. Here you can select it for both, but it is not working for SIM2 until you deselect it for SIM1 (even when SIM1 is not using mobile network at all).

I’ve had a weird situation today where despite all the notification/ringtone volumes being set, my phone would not ring or play notification sounds. I tried using DND and then disabling again, but no sounds were played. The phone would vibrate, but as I said the volumes were set correctly.

A reboot has resolved on this occasion.