English

Oooh. Ohhh. Lineage 15.1 (testing)

Thank you, how cool is THAT? Waiting for reports…

4 Likes

I’ll have to wait to see how this goes as I use my phone for work :frowning:

1 Like

This is amazing! I’m kinda tempted but should probably wait til next weekend …

Yeah, next weekend for me, too :slight_smile:

I did a complete wipe and installed lineage_FP2-ota-db37d0c8d8.zip via TWRP along with open_gapps-arm-8.1-pico-20180706.zip (beta itself, I felt daring :slight_smile: ) on an encrypted phone …

After getting past the encryption password as usual it now takes a really long time (> 45 min) to boot, showing the LineageOS animation, so while I give it some more time to sort itself out (LineageOS needs some kind of progress indicator here!) perhaps some questions @chrmhoffmann in the meantime:

  • Should installing via TWRP work, or is the recovery provided in your post required somehow?
  • Should Open GApps ARM 8.1 work theoretically?
  • A quick rundown of how to give debug info please … which files are helpful and where to find them?
3 Likes

The zip already has gapps (exceptionally, normal lineage builds don’t have them). No need to install them. It’s not normal that after a wipe you still have to enter encryption pass. I’d guess it didn’t wipe properly. Try the recovery I linked.

It doesn’t take 45 minutes to boot. Maybe 2 minutes.

Chris

8 Likes

I installed it via TWRP, more or less in the same way as described in the official installation guide of LOS.

First boot was really fast. At a first glance everything seemed to work, I checked camera, Bluetooth and WiFi. Cool to see Oreo running on my FP2. :grinning:

Unfortunately my SIM card was not recognized which is in SIM slot 2. I also can not try SIM slot 1 because I stupidly damaged it during my last vacation with one of these nasty SIM adapters… I wrote chrmhoffman a short message about my experience.

Since I need a working phone I switched back to LOS14. Playing my TWRP backup back was quite troublesome. I had to flash LOS14 first, than it worked. Keep that in mind if you run into the same problem!

I guess LOS15 is a good motivation to find a repair shop to fix my sim slot. I already have the spare part here, I just got to find someone to do the soldering job for me…

7 Likes

Hi, I have a workaround for second Sim slot, but I don’t yet how to upstream this - the cm14.1 code that allowed this is gone.
I also know how to fix drm. Stay tuned. Please continue to report non functional stuff.

Chris

8 Likes

Thanks, this is so cool.

2 Likes

Hi,
I just installed lineage OS 15.1 via TWRP latest available version.
The installation was fast. The OS is very clean and fast.
One bad thing is that this build come with gapps that I do not want to install :slight_smile:

2 Likes

Thanks, good to know. Will try again.

With TWRP that was normal until now, though, I did that several times across OSes.
To get rid of the encryption I would have to use “Format Data” in TWRP, just wiping didn’t harm the encryption.

I did. Wiped everything with it. Tried to apply the ZIP from sdcard1 …

-- Install /storage/1E04-0C32/lineage_FP2-ota-db37d0c8d8.zip ...
Finding update package ...
Opening update package ...
E: Unable to open '/sideload/package.zip': Transport endpoint is not connected
E: failed to map file
Installation aborted.

Reflashed TWRP afterwards … Encryption seems gone now, so the provided LineageOS 15.1 recovery seems to really erase it with a wipe.

Edit: Flashed the ZIP again with TWRP now … now it boots :+1: .

4 Likes

This is awesome! Thank you so much for your efforts already

Is it possible to get a zip without GAPPS? Or exclude them somehow from the installation?

3 Likes

This is just a test build. Final versions will never have them. If you guys insist, next version will not have gapps.

Chris

11 Likes

I would love that! But I cannot speak for everyone I guess…

6 Likes

I always just do adb sideload name_of_zip.

3 Likes

That would definitely be better.

4 Likes

Feedback for now:


First test:

Build installed via TWRP 3.2.2-0 (Releases)

The following things work for me so far:

  • call / be called
  • send SMS / receive SMS
  • internet via WiFi
  • internet via mobile network
  • location
  • compass
  • screenshot
  • main camera (new module, flash works correctly with Open Camera, not with the stock Camera App)
  • selfie camera (new module)
  • USB connection to PC / MTP
  • alarm
  • MyPhoneExplorer 1.8.9
  • root (Settings - Developer Settings - Root Access)
  • USB OTG
  • WiFi hotspot
  • Bluetooth (music playback, data connection)
  • FM radio
11 Likes

You could try to install OpenGApps with a config file including every Google App you want uninstalled after the OS installation.
I didn’t test this just now, but it worked for me in LineageOS 14.1 when I wanted to uninstall the Camera App. Perhaps I’ll check that out tomorrow.

Or we’ll just wait for a build without Google Apps.

1 Like

Thanks. Selinux is indeed disabled (permissive mode).

What is wrong with the stock camera app?
Chris

Flash and shot are out of sync … the flash gets fired, but the shot is taken when the flash is already off again.
I think it was the same in LineageOS 14.1, and the workaround was using Open Camera all along.

3 Likes