Oooh. Ohhh. Lineage 15.1 (testing)

Thanks for the idea. This is, what I tried:

  • Download test-build-image of Lineage15.1
  • Download GappsPico
  • make .gapps-config containing only ‘Include’ in folder with Gapps-Zip
  • in TWRP: queue first Lineage15.1, then the pico-gapps, reboot

Result:

  • Super fast booting into Lineage15.1 :+1:
  • Greeted by the G%%gle registration process :worried:

Restored my 14.1 again. Guess I will wait for the Gapps free version…

2 Likes

Wow thanks a ton @chrmhoffmann.
Does any of you flashed it with xposed?
I read someone tried and failed, but is it just a case or it wasn’t suppose to work yet?

Yes, I tried and ran into a bootloop…Will try it again, when the build without gApps is available…

what is mandatory?

are you referring to the app SELinux Switch or to SELinux (permissive or enforcing mode).

Btw, have you ever thought about integrating WakeBlock into the ROM?

It is mandatory to switch SELinux (SEAndroid, really) to enforcing to get official LineageOS builds shipped to the public (remember this topic is just about test builds for early-testing).

AFAIK, he doesn’t develop LineageOS itself, “just” the FP2 port (i.e. the device-dependent parts). As your request is a general, system-wide one, you should reach the LineageOS developers directly in their gerrit or via other channels.

3 Likes

Yeah for Oreo! (I love those coookies, best part: are vegan!) :slight_smile:
I’ll wait for a version w/o GApps and try it out aswell. I use my FP2 with 2 SIMs (private/work) so would need that functionality as well.
A question regarding back ups: if I backup everything with Titatnium Backup, will some of the system backups also work?

1 Like

With Nougat or Oreo Wakelock blocking should really not be necessary. Besides, blocking a wakelock often complicates things and gives you bursts of battery usage.
I’ve been on this path since KitKat, and stopped it with Nougat, as fighting the culprits is more worth than just blocking the warning signs.
(see the relevant XDA Threads about BBS, Amplify and Battery Time)

1 Like

Hi, did you wipe the device with the lineage recovery that I linked. Seems that there are problems with that. Can you try twrp? Btw: which filesystem? Ext4 or f2fs?

Chris

Yeah, exactly. Not discussing new features here. You can ask lineage guys on irc.

2 Likes

Dont even ask about xposed. Not supported officially by lineage.

Chris

2 Likes

Yes.
And then installing via this recovery’s ADB sideload or via TWRP didn’t make a difference.

Can do next time.

Ext4 now that I’m back on 14.1 with reestablished encryption. Didn’t check before, sorry.

Would F2FS be better?

I remember :grinning:, we talked about it a lot in Battery life in LineageOS
I have done some test recently but haven’t got the chance to update the thread yet. Hope I can spare some time soon.

1 Like

Oh yes please without Gapps will be awesome !
And is update OTA will it be possible in future ?

1 Like

When testing finishes and we got nightly official builds we will get everything we could expect from a regular ROM release of LOS’s quality. Until then, asking about those is probably futile (not about other things device- or upgrade-specific, though).

Chris regularly posts here about his developments and asks for specific questions, like the main here: is something broken for you or do you had any problem updating/booting?

6 Likes

There seems to be a bug in lineage recovery and f2fs. And lineage recovery doesn’t wipe the crypto header. So please try again with twrp until the lineage recovery gets fixed.

Chris

But encryption was gone for me after wiping with the LineageOS recovery.

To clarify:
Before my first (failed) install I wiped everything with TWRP, but didn’t format data to keep encryption in place. That was the install that didn’t boot.

After that, I wiped everything with the LineageOS recovery, and the encryption was gone. Installing the test build afterwards did work, encrypting the phone with it didn’t work.

So I take it that next time I should do everything in TWRP again, but additionally get rid of the encryption by formatting data?

Related:

“With the Android Oreo update, Google continues to polish the Android experience for all users. The update notably brings picture-in-picture mode support from Android TV, the Autofill Framework which replaces the need for password managers’ laggy accessibility services, and notification channels for more fine-grained control over your notifications. In addition to these changes, some previously root-only tweaks such as theming your device no longer require root, so there are less reasons to root your phone. Still, for those of you who do root your devices, you now have another tool at your disposal: access to the Xposed Framework for Android Oreo (8.0/8.1).”

1 Like

Is there a way to test this one while backing up my current OS (LOS+microG)?

Here’s what I do …

  • Make sure I have the install files with which I installed the old OS (+ Open GApps in my case).
  • Use MyPhoneExplorer to “Multi-Sync” everything there is to sync … complete Internal Storage, contacts, messages, photos etc. … to my PC to be on the safe side with a data backup.
  • Make a full system backup in TWRP and copy that to my PC.

Then I can wipe and format and test all I like, and if I want to have the old system back …

  • Wipe everything in TWRP.
  • (In case encryption is gone … disassemble new camera modules, install the old OS and immediately encrypt the phone again, encrypts very fast this way because there’s almost nothing in Internal Storage … reassemble new camera modules.)
  • Restore the TWRP system backup.
  • (In case the phone doesn’t want to boot afterwards, install the old OS again over the restored backup, this got it to boot reliably for me.)
  • Boot the old OS and use MyPhoneExplorer to “Multi-Sync” all my data back to the phone

And voilà … back on the old system as if nothing happened :slight_smile: .

Edit for a slight correction: My ringtones aren’t back after the restore.
The system backup restores the ringtone settings, but as my custom ringtone files don’t come back until Internal Storage gets restored, the OS cleverly reverts to default sounds.

3 Likes

Cheers AnotherElk, that could be a nice one for #backup or something.

Gonna give it a whirl when I’m sober. I forgot about that MyPhoneExplorer application and used Titanium Backup in the past. How are people on non-Windows doing this?