Oooh. Ohhh. Lineage 15.1 (testing)

I’d love to know if the ROM is pre-odexed prior to trying to install it, @chrmhoffmann, could you maybe dispel my doubts, please? :slight_smile:

Is there a workaround to poweroff the phone? And how can you get to TWRP if the reboot to recovery doesn’t work?

Take the battery out.

See #dic:recoverymode :

Or type adb reboot recovery when you are connected to a PC.

2 Likes

To get to TWRP just press the volume-up button during the restart of the phone or when turning on the phone (until it vibrates).

You can power off either from TWRP or (when your phone is encrypted) from the screen where you enter your PIN/password to decrypt the device.

Edit: @Stefan was faster :slight_smile:

1 Like

No, that’s the thing that is broken with Lineage 15.1 :wink:

No, adb reboot recovery works fine here on lineage 15.1. The problem is the new camera module that must trigger some bug in kernel, so it crashes (or some other problem).

Chris

I think it’s odexed.

Chris

Yeah, forgot to mention about the new camera module.

But then the question was how to do a poweroff when the poster was affected by the new camera module problem. If you can’t poweroff then you also can’t adb reboot recovery because of the new camera module. Just happened for me a couple of minutes ago :wink:

Vol Up while rebooting brings you in recovery.

1 Like

Hi, Could you post the fiddling you did, so that the others can easily do it? Thanks!!!

@vthejay

I couldn’t run the script from within lineage, and got errors running it in twrp.

I used the zip referred to in the wiki in the end.

However I don’t know if that actually made the difference as of tried that before.

The short answer is no, unfortunately I can’t tell you what actually made the migration work successfully for me. I made 7 or 8 attempts in all

1 Like

This migration zip here worked for me.

2 Likes

Thanks. I’ll wait for Lineage for microG then, to avoid blocking me off. Thanks for all the work! :+1::top:

1 Like

Thanks for this new release !

I use LOS 14.1 (20 june 2018) and I wanna install the build from 4th august.
How is it working ? I just flash it with the SU and then everything is done ?
Am I going to lose any settings on my phone or apps ?

Thanks for support

It would be better to wait until the official build of 15.1 hits this week (tomorrow maybe?). The 4th Aug is an unofficial build and you’d then need to take additional steps to migrate to the official build.

When you do upgrade on the official build, you won’t loose any settings/apps.

This post contains details of how to upgrade ONCE the official version is available to download (don’t forget if you’re using gapps that you need to flash gapps for 8.1 before you reboot after flashing the new 15.1 build).

3 Likes

Thank you. I will wait until the official release of 15.1 ! I guess it’ll be available for download on this forum as soon as it’ll be released.

Probably not directly, since the bulds are provided on a LineageOS server. You’ll find the download here
https://download.lineageos.org/FP2
Just check for the latest 'nightly" 15.1 build.

1 Like

Just installed the new 15.1 incl. microg. Upgrade went smooth. I did a System wipe to be sure, eventhough on the microg page it was said that no wipe at all is necessary.

Everything seems to work fine at the moment. However I don’t get the weather Information working in th Clock app.

Booting time did not change a lot I have the feeling. Apart from some nice design changes I did not see many other changes yet!

Thank you very much for your effort!! One step more to use the phone longer!

Best Leon

6 Likes

Same here.
Just installed Lineage for microG without wiping anything and it worked!
Everything works as it should.
Thank you very much for making Lineage OS 15.1 happen for FP2!!

Cheers!

3 Likes

Nice to know there’s people working on a native exchange connector. I’ll wait for a bit more, would like to avoid Gapps if possible.