Oooh. Ohhh. Lineage 15.1 (testing)

As far as I know twrp decryption works if the device was encrypted with 14.1 (and then upgraded).

Chris

3 Likes

What?! Excuse me, but are you sure? :scream: Does UnifiedNLP’s self-check reports all is working?
UnifiedNLP needs (at least) the privileged permission android.permission.INSTALL_LOCATION_PROVIDER on each boot and Android 8+ needs an special permission whitelist file which I didn’t started working on until yesterday.

So you think it will get included, in the end, with some delay?

I unfortunately need Exchange/ActiveSync to sync my work mail/calendar/contacts. No 15.1 for me, yet… :slightly_frowning_face:

UnifiedNLP’s self-check reports the same as with lineage OS 14.1 - screenshot from today:

2 Likes

Uh! Thank you! Good to know. Maybe the permission is only needed once, not in every boot, so Android registered UnifiedNlp as a location provider in Nougat and passed it configured to Oreo just fine. I doubt however it would work if installed newly on Oreo without the permission whitelist file, though.

Yes, you can use gmail’s exchange connector, too (if you have gapps).

No ETA for native lineage exchange connector. You can monitor progress here:
https://review.lineageos.org/#/c/LineageOS/android_packages_apps_Exchange/+/211382/ and https://review.lineageos.org/#/c/LineageOS/android/+/213705/

Chris

3 Likes

I’d love to know if the ROM is pre-odexed prior to trying to install it, @chrmhoffmann, could you maybe dispel my doubts, please? :slight_smile:

Is there a workaround to poweroff the phone? And how can you get to TWRP if the reboot to recovery doesn’t work?

Take the battery out.

See #dic:recoverymode :

Or type adb reboot recovery when you are connected to a PC.

2 Likes

To get to TWRP just press the volume-up button during the restart of the phone or when turning on the phone (until it vibrates).

You can power off either from TWRP or (when your phone is encrypted) from the screen where you enter your PIN/password to decrypt the device.

Edit: @Stefan was faster :slight_smile:

1 Like

No, that’s the thing that is broken with Lineage 15.1 :wink:

No, adb reboot recovery works fine here on lineage 15.1. The problem is the new camera module that must trigger some bug in kernel, so it crashes (or some other problem).

Chris

I think it’s odexed.

Chris

Yeah, forgot to mention about the new camera module.

But then the question was how to do a poweroff when the poster was affected by the new camera module problem. If you can’t poweroff then you also can’t adb reboot recovery because of the new camera module. Just happened for me a couple of minutes ago :wink:

Vol Up while rebooting brings you in recovery.

1 Like

Hi, Could you post the fiddling you did, so that the others can easily do it? Thanks!!!

@vthejay

I couldn’t run the script from within lineage, and got errors running it in twrp.

I used the zip referred to in the wiki in the end.

However I don’t know if that actually made the difference as of tried that before.

The short answer is no, unfortunately I can’t tell you what actually made the migration work successfully for me. I made 7 or 8 attempts in all

1 Like

This migration zip here worked for me.

2 Likes

Thanks. I’ll wait for Lineage for microG then, to avoid blocking me off. Thanks for all the work! :+1::top:

1 Like

Thanks for this new release !

I use LOS 14.1 (20 june 2018) and I wanna install the build from 4th august.
How is it working ? I just flash it with the SU and then everything is done ?
Am I going to lose any settings on my phone or apps ?

Thanks for support