Oooh. Ohhh. Lineage 15.1 (testing)

This is just a test build. Final versions will never have them. If you guys insist, next version will not have gapps.



I would love that! But I cannot speak for everyone I guess…


I always just do adb sideload name_of_zip.


That would definitely be better.


Feedback for now:

First test:

Build installed via TWRP 3.2.2-0 (Releases)

The following things work for me so far:

  • call / be called
  • send SMS / receive SMS
  • internet via WiFi
  • internet via mobile network
  • location
  • compass
  • screenshot
  • main camera (new module, flash works correctly with Open Camera, not with the stock Camera App)
  • selfie camera (new module)
  • USB connection to PC / MTP
  • alarm
  • MyPhoneExplorer 1.8.9
  • root (Settings - Developer Settings - Root Access)
  • WiFi hotspot
  • Bluetooth (music playback, data connection)
  • FM radio

You could try to install OpenGApps with a config file including every Google App you want uninstalled after the OS installation.
I didn’t test this just now, but it worked for me in LineageOS 14.1 when I wanted to uninstall the Camera App. Perhaps I’ll check that out tomorrow.

Or we’ll just wait for a build without Google Apps.

1 Like

Thanks. Selinux is indeed disabled (permissive mode).

What is wrong with the stock camera app?

Flash and shot are out of sync … the flash gets fired, but the shot is taken when the flash is already off again.
I think it was the same in LineageOS 14.1, and the workaround was using Open Camera all along.


Hey, Chris, great work! I’ve been following your commits, but didn’t expect a testbuild that soon. I’ll maybe test that in a few days (pending work here for the moment).

BTW, for anyone #livingwogoogle interested, my microG flashable installer doesn’t work for Oreo yet. An update is in the making and I hope to have it working for the stable 15.1 release, though.


If you do not find someone near your location, I can offer my soldering skills. Its far to drive, but if you can arrage yourself some days without a Fairphone, you can mail it to me.


Now after charging, the LED stays off.
I was pretty sure it indicated the battery status until I plugged in the charger, but probably it indicated something else then. It makes more sense that it doesn’t work at all for the battery status.

Edit: Confirmed on second test install … LED doesn’t work for the battery status.

Hi everybody,

I ran into a bootloop when I installed the build with xposed for Oreo…So, I reverted back to the nightly 14.1 build… I will wait for the next buid without gApps and then give it a try…

Thank you so much @chrmhoffmann ! That’s great news. And apparently, a big bunch of necessary functions are working well! As I use, and am currently very satisfied with LOS+microg I’ll wait for the first nightly before changing to LOS15.1 !


The encryption-flag is sometimes within the partition header. Use the format data option in stead of the wipe data (with twrp) if the problem persists.

1 Like

Will be SELinux Switch be compatible with it later on?

Yes, it’s mandatory to be switched on when getting official nightlies.



I just did some reading again in the article I referred to, and it is even easier.

If you want to have a certain Open GApps package … just install it, it will uninstall all Google Apps it finds on the phone before it installs itself.
(I just did that with Open GApps pico, and it looks like it worked … the “Google” thing that was there on the home screen before is gone now, there’s just what pico installed - some basic services and the Play Store).

If you want to have no Google Apps at all, theoretically a config file just containing “Include” and nothing else should do that for you. Installing any Open GApps package with this config file should then uninstall all Google Apps before installing itself with this config file telling it to install … nothing. I didn’t try this, though, so use at your own risk :wink: .

1 Like

@chrmhoffmann I tried to encrypt the phone with the test build, but failed.

I disassembled both new camera modules, wiped everything, destroyed the LUKS header and reformatted userdata, freshly installed the test build, set up a PIN for the lock screen (it seems encryption uses that as the password) … no encryption.

Once started, an encryption attempt reboots the phone completely back into LineageOS. Somewhere inbetween the reboot procedures it should display the Android robot and encrypt, but doesn’t.

I just reverted back to LineageOS 14.1 again … which after the otherwise same steps successfully encrypted the phone, so it seems to me it’s the test build, not some other factor.

Yeah I just verified this issue in LOS 14.1 (with microG). The application Simple Camera from F-Droid doesn’t suffer from this issue, though Open Camera doesn’t either.


Thanks for the idea. This is, what I tried:

  • Download test-build-image of Lineage15.1
  • Download GappsPico
  • make .gapps-config containing only ‘Include’ in folder with Gapps-Zip
  • in TWRP: queue first Lineage15.1, then the pico-gapps, reboot


  • Super fast booting into Lineage15.1 :+1:
  • Greeted by the G%%gle registration process :worried:

Restored my 14.1 again. Guess I will wait for the Gapps free version…