English

Oooh. Ohhh. Lineage 15.1 (testing)

lineageos
Tags: #<Tag:0x00007fefbddcf460>

#127

I just installed the newest testing version, and I wanted to leave my story about it here:

First install - great, everything’s fine, but hey, the device is not charging! Ok, maybe something went wrong during the flash procedure, so let’s repeat this.

Second install: everything’s fine, but hey, it is not charging. Going back to 14.1, frustrated. Back at 14.1, the device is not charging at all!

But it is hot as h :japanese_ogre:

Ok, let’s cool it down. Now the charging works.

Re-flash 15.1, taking off the backcover, and leaving the phone on the cool kitchen sink. Et voila, the device is charging with my special heat sink…

Lessons learnt for today: FP2 protects itself when it becomes too hot and will not charge…


FP2 stopped charging any battery with any charger
#128

Love your heat"sink" :smiley:


#129

New build available (see 1st post).

Fixed:

  • FM radio works again
  • Notification LEDs should work now

Last remaining issues (at least for 8):

  • Some users here have noted strange behavior with MultiSIM (PIN requested randomly). Can someone confirm that this is not working? I don’t have two SIMs at hand this week.
  • Backlight does not power on again in Offmode charger (but it keeps charging). The battery is shown for a few seconds, and then you cannot bring the battery anim back on. Seems to miss a kernel fix for this.

The other reported issues:

  • Reboot into recovery: I cannot reproduce this. Can someone confirm that this is broken?

New cam module issues - They are not new in O and I think they also exist under Fairphone OS:

  • Camera flash not in sync with picture taking using Snap app (built-in camera app): I think this was already on cm-14.1.
  • Shutdown make it reboot: This is also with Fairphone OS apparently and not new in O.

#130

Will check. Unfortunately there was just one mirror and that’s providing only 40KB/s :smiley:


#131

Yep, instead of booting to TWRP, the phone boots to the launcher/desktop. I have the new camera modules.


#133

I’m a bit concerned about the encryption situation. For now that’s a dealbreaker for me.

The LineageOS 15.1 test build can encrypt. That’s fine.
Current TWRP cannot decrypt this then. That could well be. But why?
What changed from LineageOS 14.1 (Android 7.1) to 15.1 (8.1) at this front?

What concerns me here is that the internet reports for months now that the respective TWRP on several devices can’t decrypt Android 8.1 encryption … and somehow there was no noticeable movement apart from a few fixes in non-official TWRP builds for certain devices. And now here we are on the official LineageOS/ official TWRP device Fairphone 2 with the same problem.

I somehow imagine a scenario now where the LineageOS side would think “Well, fix TWRP then!”, while the TWRP side would think “Well, fix LineageOS 15.1 then!”.

I do my system backup with TWRP. I briefly looked into other ways (dd-ing the encrypted partition block or using adb backup), and I’m not enthusiastic about moving away from the very convenient TWRP backup.

So, any definite idea who has homework to do? LineageOS 15.1 or TWRP?


Lineage-16.0 (Android Pie) Beta
#134

TWRP has.


#135

Do I have to wipe to install this build?
I could test the 2 SIM PIN problem again.

Another difference to 14.1: I cannot define, which of my screens should be my home screen. The system always chosses the most left screen. Does anybody know how to change this?


#136

No, you don’t have to wipe.
Chris


#137

Press and hold on a home screen until the screens zoomout and you get the various options to add widgets etc. On the tiles above you can switch between your screens and you should notice a little house. Tap this on the screen you want to be your main screen and you’ll see the circle goes white… and that’s it :slight_smile:


#138

So, I took the plunge this morning and installed since all the big bugs are off the list now (and I don’t have the new camera modules anyway)

I was on an encrypted device, so have started from scratch which I was planning to do at some point soon anyway!

Everything seems to be a-ok.

I’m a little confused about encryption though, as I do need to use encryption. Should I flash the recovery from post 1, then encrypt and that should work fine?


#139

Try to encrypt, it should work.
If it doesn’t, start from scratch and take the steps given here.

As long as you don’t need TWRP to be able to decrypt the data partition (which TWRP can’t as of version 3.2.2-0), everything should work fine.


#140

With the version of 28th I still have one problem with the LED. I’m currently charging while the phone is on, but the LED was not lit. Then a notification came in, the LED went on, just to go off after a short while. Now, several minutes later the LED is on again. And just as I type it went off.

Edit: and I can confirm that adb reboot recovery and adb reboot bootloader both do a normal system boot (I have TWRP 3.2.1).


#141

OT: Can 3.2.2-0 decrypt 14.1?


#142

Yes. No problem there.


#143

Hi,
that was so in Lineage 14… but not in 15 (Oreo). You’ve now installed it aswell, go have a look :stuck_out_tongue_winking_eye:
I’m still searching for an answer… I’d hate to change my habits with my home screen.
Regards
Fred


#144

Oops, I’m using Nova Launcher, forgot about that :stuck_out_tongue:

Not sure that Trebuchet for 15.1 allows that. Probably have to use a custom launcher…


#145

I’ve so far not had any dual SIM problems. I do not have a pin assigned to either SIM though.


#146

Ok.
Interestingly there seems to be similar trouble over at Fairphone’s Android 7 beta when LinageOS based on Android 7 never had this … maybe it’s the same problem and Fairphone will do the necessary homework at least for their TWRP build … I’ll take anything that works :slight_smile: .


#147

At current state, I’ll have to provide self compiled twrp. I’ll post back here when it’s available. Until then keep reporting bugs :slight_smile:

Chris