Official LineageOS 20 FP4

Installation went perfectly, official lineageos is installed, 2nd camera locks up when used.


Does the wideangle camera working in Lineage OS? Does the 48 MP-Resolution working?
Is Volte and VoWIFI ok?

1 Like

Not tried it yet but AFAIK until Fairphone themselves fixes it external apps cannot use the wideangle camera? They do some non-standard stuff with the access to the camera.

I wish they were more open about both the intent to fix the software issues and the progress on them. For a phone this open to repair, the bad software side (camera, ARcore, that kind of stuff) is really annoying. I hope LineageOS can find custom fixes though, at least with root we can fix the missing ARcore.


Does the wide-angle camera working in Lineage OS? Does the 48 MP-Resolution working?

Well, the wide angle lens should work as it also works with FPOS and Gcam. A solution how to access the 48MP would be great though, for LineageOS and FPOS.

1 Like

Wide angle works fine can’t test Volte and VoWIFI.

How is connecting to a Windows PC working for you guys? After reinstalling mine doesn’t show up in the explorer anymore. ADB still recognizes it and I’ve set it to file transfer

I run Linux, but had no issues. Make sure you have the correct USB drivers installed, for me it shows up as “Google Inc. Nexus/Pixel Device (MTP + debug)”

It’s telling me that Android ADB Interface is the only compatible driver and I failed to check which one I used earlier… There’s always something I forget when making backups

Edit: Welp, it’s no longer showing up in ADB either. Guess something else is wrong

Edit 2: Now I’ve got it showing up in explorer but still not in ADB. I don’t even know what’s happening

Edit 3: Nevermind, my phone thought disabling USB debugging would be a funny prank. I’ve reinstalled the driver as “SAMSUNG Android ADB Interface” and now both works

Thanks for the microG-build @tfbb!
Would you mind building another up-to-date image? I would build it myself, but it seems like 24 GB of RAM aren’t sufficient for that any more… :see_no_evil:

1 Like

Quick question, is rooting via still a thing? Cause installing via fastboot flash boot patched.img gives me this:

target reported max download size of 1073741824 bytes
sending ‘boot’ (98304 KB)…
OKAY [ 3.082s]
writing ‘boot’…
FAILED (remote: size too large)
finished. total time: 3.088s

Which doesn’t really help me since the max download size is way larger than the file

You might want to take a look over here: Installation | Magisk

1 Like

Yeah, that is exactly what I’m doing, it just doesn’t work. I tried patching the boot.img again but after having been in fastboot and restarting the phone Windows again doesn’t list the it in the explorer. When I set “Use USB” to PTP it does show my phone and I can see the pictures on it but when I set it to File Transfer nothing happens (ADB still detects it)

Are there official Fairphone USB drivers? Or which ones should I use?

I use Linux, so I have no idea about driver stuff, sorry.

1 Like

I fixed the “not being able to install a patched img” by sideloading the zip so my only problem is not being able to transfer files via USB. That is going to be very annoying but at least I can live with that as long as my phone is rooted

No it does not work with Gcam. However it works on e/OS, Iode and CalysOS


@t_aus_m : regarding a new build: I’ll do so in mid-January - that’s when the monthly lineageos-updates will be merged into the repos. And yes, building lineageos on desktop hardware is getting next to impossible :confused:
fwiw, the FP4 is now officially supported by lineageos: Changelog 27 - Thriving Thirteen, Amazing Aperture, Careful Commonization – LineageOS – LineageOS Android Distribution . builds on should become available soon, i guess :slight_smile:


Hello, first post here but I lurked for some time :slight_smile:

I started building microG images a while ago, you can find them here:

Here’s the latest:

Images have the OTA update url set to my server so whenever I’ll build an image it will show up in the updater.

I’m using test keys, I’ll stop building images once lineage4microg will start building for FP4 and lineage 20 in general.

Just FYI I’m building the images on my laptop with 16GB RAM, I’m adding 16GB swapfile and the build successfully completes :slight_smile:

For completeness here’s my build command:

sudo docker run --rm \
    -e "BRANCH_NAME=lineage-20.0" \
    -e "DEVICE_LIST=FP4" \
    -e "SIGNATURE_SPOOFING=restricted" \
    -e "WITH_GMS=true" \
    -e "PARALLEL_JOBS=12" \
    -e "OTA_URL=" \
    -e "ZIP_SUBDIR=false" \
    -v "$PWD/lineage:/srv/src" \
    -v "$PWD/zips:/srv/zips" \
    -v "$PWD/logs:/srv/logs" \
    -v "$PWD/cache:/srv/ccache" \
    -v "$PWD/manifests:/srv/local_manifests" \

fp4.xml manifest:

<?xml version="1.0" encoding="UTF-8"?>
  <remote name="device" fetch="" revision="lineage-20" />
  <remote name="kernel" fetch="" revision="lineage-20" />
  <project path="device/fairphone/FP4" name="LineageOS/android_device_fairphone_FP4" remote="device" />
  <project path="kernel/fairphone/sm7225" remote="kernel" name="LineageOS/android_kernel_fairphone_sm7225" />

microg.xml manifest

<?xml version="1.0" encoding="UTF-8"?>
    <project path="vendor/partner_gms" name="lineageos4microg/android_vendor_partner_gms" remote="github" revision="master" />

Thanks for your response. Just fyi, mid-Janurary will also be the time when the Lineage4microG-build will probably be available, as per Lineage 20 by bananer · Pull Request #366 · lineageos4microg/docker-lineage-cicd · GitHub


Welcome to the forum and thank you very much for the builds!
I’ll probably test yours some time this week and also switch once the “official” Lineage4microG is available.
Your build-setup sounds interesting. I’ve tried building on two machines so far: My desktop PC with 16 GB of ram and 16 GB of swap, on there the build fails even with only two concurrent jobs. My notebook has 24 GB of ram but no swap and of course also failed. I’m using the docker image for building. How about you?

Thanks :slight_smile:

I’m using the build as daily driver and no issues so far.

I’m building on my laptop which is an AMD Ryzen 7 4800H with 16GB RAM + 16GB swapfile, concurrency is set to 12.

I leave the build running overnight without any other SW running. Having cache enabled I’m not sure about build time, last took only 40minutes.

One thing I overlooked a couple of times and led to failures was that I wasn’t using lineage-20 image tag.

Hope it helps

1 Like