Official LineageOS 19 for Fairphone 3/3+

I can confirm hat the WiFi issue seems to be solved. Downloaded two different ISO images (2 gb) an there was no WiFi drop as in the past. Many thanks for your effort @TeamB58 .

3 Likes

What is everyones battery life like here? I was never overly impressed with the FP3+ but it got me by. Without using my phone, it currently has 12h remaining from 71% and can often just lose a chunk of % when idle for no reason. Definitely just about getting through the day with some moderate use of browsing and music, nothing I’d consider excessive.

I tried BetterBatteryStats but the app kept resetting and losing the ADB command before I could get any worthwhile data.

Hi,
I still have problems with the wifi, even with the version lineage-19.1-20220919-nightly-FP3-signed.zip.
When the device loses wifi in standby, it doesn’t reconnect until I wake the device up.
I have mobile data turned off, so the device is really offline during this time.
Or maybe the fix is only in the unofficial version?
LineageOS 18 did not have this problem!
thanks

Are you using Gapps or MicroG? In Microg-settings you can configure how often it has to reassure the connection in sleepmode. I lowered it to every 10min for my Wlan-network (FritzBox 7530) to prevent disconnects.

Alternatively you could try to reset your network-settings: (Settings>System>reset options>wifi, mobile & Bluetooth)

Can anyone reconfirm this please?

I just now flashed and downloaded a 5GB file and it worked fine.

I feel mine is lower with LOS 19 than what it was with LOS 18.
I’m losing the first 10% in the few minutes following device unplug.
Today I’ve already lost almost 25% of my battery, only 1h30 after unplugging it

1 Like

I confirm this.
I started a Debian DVD ISO (3.7GB) download and the Wi-Fi disconnected at 20%.
I kept the screen on, so it doesn’t seem to be an related to standby.

My message above is wrong, sorry. I was connecting through a faulty Wi-Fi router.

When connected through a reliable one, no Wi-Fi download issue when screen stays on but the Wi-Fi connection drops when I switch the screen off.

Hi, thanks for your answer
I use Gapps (Mindthegapps), where is this timeout-setting to find here?

I reset the network-settings one more time, then I left and re-entered the wifi area, result:
The connection was not restored in standby.

As long as I am in the wifi range the connection stays up, also in standby, and also the whole night, but as soon as I leave the range it is not established anymore.

As far as I know with Gapps it is adjusting this value automatically. But I remember there have been third-party-apps to change it, not sure if this is still a thing. How long it takes until a connection is terminated depends on your wlan-router and for mobile data on your ISP.

But I am not sure if it only terminates the connection to connected servers (like a push-server for notifications) or if it terminates the whole internet-connection. It has been quite some time since I had to deal with this stuff, so I don’t remember exactly everything.

But to be honest, the more I think about it the more I feel like this is probably not the solution to this problem. Still worth giving it a shot though.

I also don’t think it has anything to do with push services, besides I use fairemail…
Nevertheless thank you for your answer

10h off charge from 100%, just under 3h screen usage (reddit app, texting, and a Boggle type game mostly) and I’m on 35%. It’s 19:30 so it’ll definitely have to go on charge again tonight, whereas I was usually able to keep it on overnight and charge in the morning.

Despite my love for what LineageOS offers me, I’m tempted to do a complete wipe and return to the stock rom just to see if that helps me at all.

Hi and thanks for you awesome work!

I am wondering if the automatic builds are functional on the lineage+microg side ?
Last build a bit more than a month old. The irregularity of previous builds makes me think that maybe they were manually triggered ?

3 Likes

Hi everyone
I am running the build from 22/08/2022.
I was trying to update to 26/09/2022 OTA with system running while installing. But the process took hours, so I aborted. Now I’m trying with 19/09/2022, but here the same, it has been installing for 12 hours now and still not finished.
Shall I wait for it to finish? Can I install manually via recovery? If so, do I need a GApps package?

Have you gone back to stock rom yet? Has it helped at all?

I haven’t yet, but what I did do that seems to have done something positive is root (previously just had an unlocked bootloader) and enable 1gb of zram.

I had to root to get my banking up working again, but the zram change may have done something to help? This is my current stats from 100%. I still think something is slightly funky, as my signal should not be that high when I’m on WiFi as much as I can be, and some other app % seem way too high. But I’m happy I can idly get through a solid day and a half for now.

Hi, is this:
https://review.lineageos.org/337422
The fix for the missing call sounds? That would be really great. It is more annoying than I thought…

Indeed. Merged and should be fixed in next release.

2 Likes