Official LineageOS 19 for Fairphone 3/3+

Hi. I just got hold on a FP3.

  • I installed twrp-3.6.2_9-0-FP3.img
  • I booted to recovery, did format data, wipe data etc.
  • I sideloaded lineage-19.1-20220829-nightly-FP3-signed.zip
  • before rebooting, I sideloaded NikGapps-core-arm64-12.1-20220830-signed.zip

Well, upon booting, the LOS part runs along fine, but I keep getting messages that some Google app crashes. And if I launch the play store, nothing happens.
Did I miss something ?

After flashing los, you have to reboot to recovery, to switch slots, and then sideload gapps. This way, you installed gapps to the then active slot, which probably was the slot with stock

1 Like

Thank you, you pointed me to the right direction. Now it works.

For the record, here is what I did:

  1. OEM unlock. For me, this way was simple and worked.

  2. Boot to fastboot (aka bootloader) mode

  3. Boot to TWRP recovery with the following command: fastboot boot "C:\whatever\twrp-3.6.2_9-0-FP3.img"

  4. On TWRP recovery, install TWRP (Advanced > Flash Current TWRP).

  5. Format data, wipe data etc.

  6. Sideload LineageOS: adb sideload "C:\whatever\lineage-19.1-20220829-nightly-FP3-signed.zip". In the displayed logs, note the slot on which it is installed (A or B).

  7. Still on TWRP, go to Reboot, tap on the slot noted above, and then boot to Recovery.

  8. LOS’s recovery boots (why did LOS’s recovery overwrite TWRP? Too bad IMO), sideload NikGapps-core-arm64-12.1-20220830-signed.zip.Upon warning Signature verification failed. Install anyway? answer Yes (IIRC, on TWRP there would have been no such warning).

  9. Reboot to system. Check that everything works.

  10. (optional) Reboot to (LOS’s) recovery and sideload Magisk-v25.2.zip. If warned that there’s a signature problem, tell it to keep on.

  11. Reboot to system

  12. (Todo) Reinstall TWRP

Well, I just took the plunge, and things are going weird:

  1. booted to flashboot, booted to TWRP recovery.

  2. On TWRP recovery, install TWRP (Advanced > Flash Current TWRP).

  3. Now, if I ask a reboot to system, it actually boots to recovery (TWRP). From TWRP’s File Manager, all folders (eg. /data/adb, /data/data, etc.) show files and folders with gibberish names, so I guess there’s some encryption problem.

  4. Reboot to bootloader

  5. Request the installation of LOS’ recovery: fastboot flash boot "C:\Users\whatever\lineage-19.1-20220829-recovery-FP3.img" [1]

  6. get the message fastboot: **error: boot partition is smaller than boot image**

  7. try fastboot boot "C:\whatever\lineage-19.1-20220829-recovery-FP3.img"

  8. Weird: phone boots to system, and not LOS’s recovery as expected

  9. System works fine (except that magisk is gone)

  10. Request power down. Phone actually reboots and gets stuck to the Fairphone logo.

  11. Manually force reboot

  12. Loop to 3

Edit 1:
[1] actually, fastboot flash boot_b "C:\whatever\lineage-19.1-20220829-recovery-FP3.img" (note the “_b”) does work, and I can boot to LOS’s recovery, install magisk, and boot to system, but I get stock on the Fairphone logo, while I can access its contents from the PC, and adb is responsive, too. I’m puzzled…

Edit 2:
So I go to LOS’ recovery, factory reset: device boots fine, Play Store works.
Reboot to LOS’ recovery, install magisk: same as in edit 1: the system does boot (I hear notification sounds, I can adb the system), but the display is stuck on the Fairphone logo…

I never installed TWRP on the a/b device, just use the temporary boot mechanism from bootloader. Also, patching the boot with magisk I’m doing via

  • transfer ota los to computer (after hitting export in updater)
  • extract boot.img
  • transfer back to phone
  • directly patch image with magisk app
  • transfer back the patched image to computer

And after applying the update i dd the boot image on the appropriate boot partition and reboot. It’s a bit of a hassle right now as applying the ota makes lots of apps and services crash and magisk is inoperable afterwards

1 Like

Yes, it looks like twrp can’t decrypt the current encryption method

Hi All,
Sorry for the delay. I haven’t forgotten about the two critical issues being discussed here:

  • WiFi getting disconnected when downloading large files
  • No ring back tone heard sometimes during IMS call.

For the WIFi issue, it’s actually a mistake from my side.
More details: Kernel is a very vast ocean to be honest. When I started working on Android, I had no knowledge on kernel but slowly I started to learn. When I joined LineageOS for FP3, the kernel was outdated and we had to restart from a fresh baseline. While doing so, I had no reference for WIFi driver in-lining into kernel sources as staging: prima: merge fairphone prima into kernel · LineageOS/android_kernel_fairphone_sdm632@10fa4c9 · GitHub definitely could not be taken as it is. This commit had a squash of many things which were unclear and even unsupported for newer tag from QC.

So, I referred a few commits here and there to get the kernel sources ready. While doing so, one or more faulty commits might have been added. In fact, I even had a test build with separate thread and this issue was not reported then.

Solution: It became very complicated to identify the faulty commit(s). So, I had to create a fresh source altogether. But this time it’s based on stable kernel(4.9.325) which will be mandatory since 2022-09-05 SPL in order to address CVE-2022-23960. In case anyone’s interested, here’s the kernel source which will be used for LineageOS 20 as well.

Regarding ETA for this fix: This would again require approval from many people as this requires a change of kernel source. So, the fix might not be available until mid of this month.

In the mean time, if any body would like to try out test(unofficial) build then here it is.

For the ringback tone issue, there’s a feature which is something that has been newly added by AOSP in Android 12. A workaround to disable this feature for legacy devices has been submitted but still pending review. Corresponding device side change can be found here.

Thanks once again for your continuous support. Do inform if there are any other critical issues that has to be addressed on priority.

Thanks.
TeamB58.

6 Likes

Thanks for the update. <3
Can you or @dk1978 have a look into this issue? Snoozing via shaking or turing down the device does not work. Very annoying for all night owls out there. :wink:

Hi. Just did some dirty flashing on the tricky FairPhone 3+ I talked about just above:
Form LOS’ recovery: adb sideload "C:\whatever\lineage-19.1-20220902-UNOFFICIAL-FP3.zip"
(I don’t know if I should have reflashed NikGapps or Magisk. Anyway, I didn’t so far)
And then I rebooted to system. I’ts been 5or 10 minutes I have the animated LOS logo, is that expected?

If you were on 18 before, then yes there are the old gapp, causing trouble.
Flash los, reboot to recovery (not system!) for switching slots, sideload gapps, and reboot.
Also, if you want root, you’ll have to make a patched boot.img, installable e.g via temporary booted twrp.

No, I was on 19.1 before.
I’m still on the animated logo, after maybe 30 mn. Trying to hard turn off and restart.
Edit: problem persists. Will try to return to LOS recovery, reflash lineage-19.1-20220902-UNOFFICIAL-FP3.zip, then NikGapps and reboot to system.

Ah, now i realize, that’s @TeamB58 unofficial. Sorry, didn’t pay attention. So, maybe, there’s something amiss with that version

Update: after a factory reset, and reflashing lineage-19.1-20220902-UNOFFICIAL-FP3.zip only, I get a system boot.
Now trying to factory reset, install lineage-19.1-20220902-UNOFFICIAL-FP3.zip, reboot to recovery, install NikGapps and Magisk
:crossed_fingers:t2:

Edit: done that. Working fine so far. Before the upgrade, LOS’ latest 19.1 seemed to drop the wifi signal a bit too easily; now it seems more stable

@TeamB58 , I tried to download a large file (Ubuntu desktop ISO), it worked just fine.
If a new OTA version goes out, will your unofficial build be able to upgrade?

I am not quite sure if we can update to the official builds without any issues(I mean, a data wipe). I haven’t tried this out.

Hi,

Just to let you know there’s one more LOS-19 user here (self-built with MicroG). I successfully upgraded from LOS-18 yesterday.

Thanks @dk1978 & @TeamB58 for your work :slight_smile:

Unfortunately, I also have the wifi problem under LOS 18 on the FP3. I know there are no more patches for this, but it would be really great if you could fix this bug there.

I decided to install /e/os today. All wifi problems are now gone and everything is stable. I think I will stay with the system for now, because a working system is more important to me than the latest version.
Nevertheless, I thank all those who work on LOS for Fairphone for the great work :slight_smile:

1 Like

Update

Really sorry to keep you all waiting. Today’s build should have the updated kernel and the WiFi issue should be resolved now.

For the other issue, the change is still in review from seniors.

6 Likes

Just now flashed the new build and things seem to be working fine. Let me know if there are any other issues that are encountered.

Thanks
TeamB58.