Official LineageOS 18.1 for Fairphone 3/Fairphone 3+

Please share some error details so that I can help accordingly.

Yep… That’s fixing the issue :slight_smile:

Also, please let us know if there are any other issues currently(apart from auto brightness issue which we are aware of). We have time before the next official build and we can fix them before the next build.

Thanks,
TeamB58.

1 Like

I experienced the same. I believe this has now been fixed by https://review.lineageos.org/c/LineageOS/android_vendor_lineage/+/314458 - have not yet tried this myself though. EDIT: I confirm this solves the issue.

2 Likes

I confirm that fixes the bluetooth issue for me - thanks!

1 Like

@TeamB58 I’m also missing my google-free Signal Messenger App “Langis” which I installed through their f-droid-Repo. Reinstallation does not work because there are leftovers in /app/data/*.tmp

But I can’t remove the app because it is not there anymore. I did also try the app directly from open whisper Signal >> Signal Android APK . But without success. Same with the App from google playstore through Aurora Store.

I don’t know why signal did break. So far I’m not missing any other apps. Luckily I have a daily backup. Any ideas? Maybe manually delete the leftovers? But how to install Magisk?

Is there anywhere the LOS18.1 built with working bluetooth? Is it possible to flash this and then switch back to the official weekly release?

Thanks in advance.

Edit:
Screenshot of fdroid Error installing langis


Screenshot of Aurora Error installing Signal

Thanks a lot to @dk1978 and @TeamB58 for making this possible!

(And thanks to the brave who tried it before I had the opportunity to install it, because I really need Bluetooth :wink: )

2 Likes

@TeamB58, @dk1978 - are there any plans to build the bootloader (lk) based on the recently published source code?

It would not only give us greater control over the bootloader, but also increased trust in it :slight_smile:

As far as I am aware of, LOS does not support building lk in tree because it’s not generic. But it can be done locally and the generated mbn file can be used.

I don’t know if we should do this. But if the users and @dk1978 agrees then I have no issues.

You mean, fresh install is not working? Leftovers in /app/data/*? Did you try removing it using adb shell? That should help remove anything.
The screenshot you have posted is showing that error because the source of the app is different(I mean, the signature is different).

Thanks,
TeamB58.

The patcher does not work on LOS 18.1 but there are some ideas how to overcome this problem for example with Riru, Riru LSP and finally FakGApps see: [MODULE/SYSTEM] NanoDroid 23.1.2.20210117 (microG, pseudo-debloat, F-Droid + apps) | Page 437 | XDA Forums

By the way LOS 18.1 for FP3 has disappeared will it come back during the week?

thank you, this works.
I have commented on the nanodroid patcher issue thread anyway, since having the patcher to work would be much easier and I think that the developer wants to know about such problems.
now I’m only missing swipe libs that don’t stay installed on this version of android, for some reasons

I had it removed because I don’t want people running into the broken Bluetooth problem. I prefer to wait until the next build coming Monday/Tuesday and do some more thorough private testing. It may also give us the opportunity to work on things like the auto-brightness which appears to be broken as well.

6 Likes

Thank You, it’s been fixed.

I confirm too the issue is solved, I did a completed successfully signed build for my FP3+ phone.

Bless You all.

I am a bit confused.
How exactly can you fix the error now? Can I download the build from somewhere?

For now you can not download it :confused: Me and others built the rom themselfes. A download on the LineageOS website is expected for tuesday, if I got it right.

1 Like

Hi,

im using the “regular” 18.1 from monday and i fond another bugs:

  • After few hours Google play services will disappear.
  • Google Play store got another bug: wont remember ur account / let you dont go in :expressionless:

Pico Opengapps from 30.7

Regards

Building fails for me somehow. Would you be able to share the built zip file? I’m curious and unpatient and don’t want to wait til Tuesday :sweat_smile:

Hello!

Thank your very much for porting LOS for our beloved FP3. <3
Is it possible to keep all system settings and apps with a seedvault backup after a wipe?

My builds are somewhat customized. Including MicroG, f-droid, signed with my own signature, pulling updates from my own OTA server. So I don’t know if it would be suitable for you :sweat_smile: If you want to try it: sure! But I can’t give you any assurance and you probably will not be able to update from my build to some other build. Downloads for my builds are here: https://build.fnordkollektiv.de

1 Like

Including MicroG and F-Droid? Man, this sounds like a dream! Thank you

Could you share a docker image to build it ourselves with MicroG and signature spoofing? :wink:

My fork of the MicroG docker stuff is here:

Just look at the build_lineage4fnord.sh and adjust the paths of the mounted volumes to a directory in your home.

Oh, and in the manifests folder you need a xml file with the following content:

<?xml version="1.0" encoding="UTF-8"?>
<manifest>
  <project name="lineageos4microg/android_prebuilts_prebuiltapks" path="prebuilts/prebuiltapks" remote="github" revision="master" />
</manifest>
2 Likes