English

Official LineageOS 17.1 for Fairphone 3/Fairphone 3+

Which ROM have you running? The official LOS one? Did you add any packages (gapps, magisk, …)?

For me the locking works fine with /e/ and the official LOS. In fact, I dont understand how it could not work, since:

  • secure-boot is disabled -> SBL is not verified
  • LOS disables verity mode -> partition hashes are not checked

But obviously I am missing something :slight_smile:
Did you check the checksum of the image before you flashed it? Perhaps it was corrupted?

FYI, in the meantime I have built my own LOS version (based on the official version), that:

  • is signed with my own keys (instead of the google test keys)
  • enables verity mode (disabled in LOS)
  • creates a ‘user’ build (instead of ‘userdebug’)

Works like a charm, all with locked boot loader!

2 Likes

@AnotherElk
Thanks! But it was a different error message - I had no possibility to force to boot the system.
There was something written like “your device/system is corrupt. the system can’t be booted […]"
EDIT: Here’s an image:

Sorry, I forgot to mention that. I’m using LOS + microG and Magisk.
But I just found a little note at the FAQ-section on the microG website:

Do you use test keys?
Heck, no! We sign all our builds with our own private keys.

So that might be the reason?
But I don’t think so since you were able to lock the bootloader with your own LOS build which is signed with your own private keys…

After flashing/booting TWRP, I always got that error message. Only the bootloader was working. But after I locked the bootloader again, the exact same image of TWRP was working again.
But I’ll try it again tomorrow.

That was a wrong memory, I just tried it again:

  • After unlocking the bootloader, the command fastboot boot twrp-3.4.0-0-FP3.img fails with FAILED (remote: Partition flashing is not allowed)

  • The command fastboot boot twrp-3.4.0-0-FP3.img fails with FAILED (remote: unlock device to use this command)

  • Booting to system or recovery ends with the mentioned error screen.

Huge thanks for the LineageOS release for FP3. I installed it last week and it works flawlessly.

This week I got a notification that a new update was available. Already? I understand from the Updater (pic related) that this is the new weekly build, dated Nov 30. Is it going to prompt me to update every week? Should I update every week?

I updated the operating system of my previous LineageOS devices a few times a year tops, is that bad practice?

When I was using LOS on my FP2 I only installed the one update per month that contained the security fixes and left out all the others.
For that I checked https://download.lineageos.org/FP2/changes/

For lineage-17.1-20201113-nightly-FP2-signed.zip it says:

Bump Security String to 2020-11-05

5 Likes

You should be able to set that notification time to a month in the three-dots menu of the updater (though that never worked on my FP2, I hope it’ll work for you).

Whether you should… I think updating once a month for the security patches is optimal and already good enough.

All depends on what you call “bad”. I don’t think it’s “bad”, but it’s always better to keep your phone sort of updated.

Btw., welcome to the forum :wink:

Edit: Ingo was a few minutes faster :wink:

2 Likes

When you say “After unlocking the bootloader” you meant in fact “After locking the bootloader”?

You cannot flash TWRP when the boot loader is locked, that is the purpose of locking the boot loader - preventing someone else to flash a modified image to your phone without data loss.

You need to:

Good luck!

1 Like

You’re right. But since I was not able to either boot to system or recovery, I tried that nevertheless. But it was somehow clear that this won’t work :see_no_evil:.
I think that maybe Magisk causes those issues resulting in a not working system.

Since you said that you have Magisk, I suppose that you rooted your phone. So I guess that the problem comes from that.

It is known that if you relock the bootloader after installing a root access the booting process will fail (because in order to gain root privileges the boot partition is altered and won’t match the bootloader’s expectations).

In conclusion : if you root your phone do not relock the bootloader.

3 Likes

@Ingo @Alex.A Thanks a lot!

2 Likes

Anyone else has battery trouble with official LOS version?

Before switching to the official, I was on the beta LOS and my battery was super good, 4-5 days. Since the last update, it is only 2-3 days.

I did have this trouble with unofficial LOS16. It was the main reason I switched to LOS17-GSI.
Considering the battery runs as good as before LOS16, I assumed LOS16 was the problem generally.


First running test with 17.1. :+1:
Already confirmed working:

  • Telephony and speakers, tethering data
  • Wi-Fi and NFC
  • Bluetooth including audio
  • FP3+ with new camera module
  • Graphics (no flickering detected so far)

Big question marks:

  • USB configuration is buggy, options for selecting MTP, PTP etc. remain grayed out. Testing a patch to fix this at the moment

All in all a very positive experience - Android has made progress. Unfortunately, I do not see any easy way to keep data and settings through the upgrade. TWRP-restoring the data partition did not work, neither did I expect it to. Some people may be lucky with other third-party backup apps. Seedvault is not available yet for 16.0.
If some people want to join me for testing, you can build using my private trees here:

or simply download this OTA package.

18 Likes

Really nice! Regarding the data/settings, I recently updated my Oneplus One from LOS 16 to 17 (dirty) and didn’t lose any data/settings. I don’t know the details on ROM level, but maybe this work can help you out on that regard?

In other news, I updated OTA to the second MicroG version of LOS 16. Works like a charm :slight_smile: Still have the latest update in my updater list though (says I can update to 10 dec version now), just like the last update.

1 Like

Very interesting. How exactly did you do the update?

The ‘usual’ way I think. Backup via TWRP, install LOS via TWRP, install extras (in this case I had OpenGapps pico installed to match my old 16 installation). All default settings AFAIK…

1 Like

Hi Micka, you saved my day with the cammand “fastboot flashing unlock”, at least you helped me to my next step. I am following the [https://wiki.lineageos.org/devices/FP3/install ] However when I start recovery my (Linux Mint) PC cannot find the device; when I start in fastboot mode I am stuck with the message “adb: usage: sideload requires an argument” although I copied exactly the command in the wiki, step 5, second dot.

Please mind “Installing LineageOS from recovery” step 5, dot 1.
The recovery program needs to be put into a mode where it waits for the incoming sideload file from the computer, only then the adb sideload command on the computer will work.

ADB doesn’t work in Fastboot Mode, only the fastboot command does.
You are supposed to use the ADB Sideload feature of the recovery mode.

2 Likes

yes I know that, but still:

Please remove the space between /tmp/ and lineage… .

2 Likes

Thank you, that was helpful. But now the output in the terminal is “Total xfer: 0.00x” and I get the message grafik. BTW the recovery mode in the FP3 shows “ADB Sideload” in red, only “Cancel sideload” is blue.
My original plan was to install from the SD-card (like I did with the FP2), but I could not find how to access it. It is still inside the FP3 with the files on it.