Öffi (public transport) - No valid install on FP Open OS 16.05 anymore


I faced trouble to install Öffi after my update but had a running version on a former FP Open OS. Even directly after full wipe no provided version was willing to run or install (“Öffi wurde beendet” or “Installation nicht möglich”). Does anyone know how to fix this, or even better does anyone has it running on 16.05 and could just pass me the according apk?

Did you use Google playstore for the apk Öffi in the previous FPOpenOS?

No I tried the Webversion and the fdroid-repo directly after full wipe. When I encountered the problem the first time (before full wipe) I tried blankstore additionally.

Edit: Sorry did not read carefully. On former self-compiled FP Open OS I installed the Webversion. Unfortunately I don’t know the Öffi-version I installed. Or chronologically:

FP Open OS (self-compiled): Öffi-Webversion working
FP Open OS 16.05 (with MicroG + apps): Öffi (Webversion, F-Droid, Blankstore) refused to install or gives error
FP Open OS 16.05 (after full wipe): Öffi (Webversion, F-Droid) refuses to install

Please install GAPPS again.
On your phone go to the webbrowser and download the F-Droidapk directly from F-Droids website.
Install it with the help from 'amaze’
The Google Playstore can only work if “location” is switch off. Perhaps that’s your problem.

Alright, but I don’t understand why I need to install GAPPS when I already had it running without GAPPS (but MicroG GMS Core).

Sorry, I thought MicroG was also a version of GAPPS.
You could try to install MicroG again and see if it works after switching off location.

I have my phone always on location, only when I have to update for instance ‘Wordfeud’ I temporary switch of location.

Alright, I got it running. Finally something which worked :joy: As I have done some steps at-once I will just report all of what I did. Starting from a full wiped system.

  1. Install XPosed through recovery
  2. Install MicroG Maps API (introduces/replaces Google Maps API) through recovery.
  3. Install FakeGApps through XposedInstaller (necessary for MicroG’s signature spoofing)
  4. Install MicroG GMS Core and GSF Proxy
  5. Install F-Droid through Web-APK
  6. Replace in-built Busybox v1.22.1 by Busybox 1.24.2-meefik
  7. Download SystemAppMover via F-Droid and make new busybox a system-app
  8. Add Öffi-repo to F-Droid
  9. Download Öffi Version 8.95-fdroid (24.09.2015)
  10. Start Öffi

I suppose the 2 major necessities are the Maps API and the Busybox update!

1 Like

there’s also a newer non google version (aosp) of öffi to download on the website. (Öffi 8.100.3-aosp)

the aosp version was in the repo before, but isn’t any more.
I asked the developer if he could add it to the repo again but unfortunately its to much work for him :frowning:
maybe if you too ask him by mail…


As @shapeApe suggested, I recommend installing the AOSP version. I also use Fairphone Open 16.05.0 without MicroG or any of the like and it works perfectly :smile: !

well… its not like i did not try the aosp version when its lying there ready-served… :smirk:
I downloaded the fastboot version

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.