Occasional mobile connectivity loss

The phone works fine as it should most of the time. I am however mostly connected to Wifi so I do not see when the problem occurs.
At times, when I don’t have Wifi enabled/I am not connected to Wifi, I notice that there is no “network” detected (although it doesn’t state that there is no network, it just doesn’t show the 4G/3G/E symbol next to the network signal strenght icon, which seems to be strong.

A reboot fixes the issue, so I assume it to be a SW issue.

Does switching flight mode on/off solve it as well?
Perhaps you could try disabling the “enhanced LTE mode” in the settings, it is a known workaround for some issues.

Enhanced LTE mode is already disabled.

Sometimes switching flight mode on/off has solved it. I do not remember though if it solves it 100% of the times or not. Last times I have chosen to reboot for some reason.

I have a similar problem. Due to lockdown I’m usually using Wifi as well.
“Cellular network” icon in the notification panel switches to “no SIM card” and the only way to retrieve network is to reboot the phone.
It happens sometimes 2 or 3 times a day, sometimes everything’s fine for a few days…

I am observing similar/same issue: my internet connection stops to work suddenly while chatting/playing/so on…, the symbol of data connetion (LTE/3G) still persist but no arrows (▲▼) are shown close to it.

Sometimes switching flight mode on/off sole the problems, sometimes after switching FM on i have no internetconnection ( the symbol of data connection is not shown) or i have no network (as if phone can’t find a cell tower). In this last case I usually reboot and everything come back to work properly.

Are you on Lineage OS or stock ROM?

My phone is running with the last version of Fairphone OS: version 8901.3.A.0066.20201119

Has the issue occurred right after the update?

I am not sure about it because during the past 2 months I have never used data nework.
I can compare last update with the previus only for 4 days and during this period i do not remember any annoyance with data network; for sure after the update I remember I had to reboot the phone to solve it at least a couple of times.

Related: Cannot start Wifi

An update:
The issue is happening quite often to me (I am not using WiFi just to see it), only this afternoon 2 times.
I made these tests:
1- erased APN and created a new one as described in iliad website. Nothing changed.
2- changed the preferred data connection from “2G/3G/4G (Auto)” to “2G/3G (Auto)” and connection worked again, then I came back and stopped. Now I am under 3G and it is working.

It seems the problem is LTE.

Following some screenshots of this.

I downloaded a network analyser to see the differences under LTE and 3G. During LTE it seems that Data Activity stays always dormant while under 3G there is movement.
Other 2 screenshots. Sorry…

P.S.: if anyone can suggest me any other test i will be glad to do it.

You could check your data plan/tariff to find out if data for LTE is allowed. Or call support of your mobile carrier.

Ah, good finding Pandalf. It might though be simply your network though.
My problem is different. I do not see the “type of network” marking next to the coverage icon.

Thanks. I called the support and they told there is some overload on the LTE network :man_shrugging: