Not able to connect to one specific router for wifi

I recently got a router to have my own wifi at home (through optic fiber). My computer can connect to the wifi without problem and so do the phones of everyone else that was visiting but for some reason my Fairphone 2 won’t connect to it. I tried to restart the router, I tried to restart my phone, I of course checked the password a million times but it won’t do. The network is marked as “saved” but the phone won’t even try to connect. I don’t have problems to connect to wifi anywhere else with my phone.
What can the problem be?

My provider is Bahnhof and my router is a Tilgin HG2711 that came with the broadband service.
I know very little about computers and phones so I haven’t tried to go in to router settings. I just took the automatic settings that were recommended by the provider, for an apparently higher security level.

Here are some informations about the router, if it can help. I don’t know what any of this means but probably someone understands it:

Dual band WiFi
Wireless 2,4 GHz: 802.11n, 3x3 3 streams (up to 450 Mbit/s*)
Wireless 5 GHz: 802.11ac 2nd gen med MU-MIMO, 4x4 4 streams (up to 1000 Mbit/s*)
1 WAN-port (1000 Mbit/s)
4 LAN-portar (1000 Mbit/s)
1 telefonport (RJ11)

I’m very thankful for any help!

Is your phone up to date? When you go in the “Updater” app, does it display “Fairphone OS 19.11.2”?
Otherwise, please check other related topics under the tag #wifi, for example:

Yes, my phone is up to date.
I’ve been looking up for other posts about wifi but the problem for others is always that they generally can’t connect to wifi. My phone CAN connect to wifi, but just not to mine.

Well in the topic I showed, it is the same problem. It is mainly to his/her home wifi that he/she can not connect.

Edit: You could try this:

Ok, yes. Sorry I first read to fast over the link you sent. I’ll try this thing with changing settings of my phone or of the router.

1 Like

On a side note: :warning: Never do things that you don’t understand. If you don’t know what settings you are changing, please ask. This will avoid breaking anything.

Thanks for this side note. That’s why I wanted specific help, because I don’t dare to start trying out things when I have literally no idea what all these things are about 5 GHz or 2,4 GHz and WAN and LAN…
But I’ll try the things on the link you sent.

1 Like

Little update on my situation…
After we wrote last Monday I tried different things:
I’ve try to change location mode on my phone, as you suggested from the other post. It didn’t help. And anyway most of the time my location is off. I don’t like knowing I can be tracked wherever…
Then I was for at least two hours on a help-service of my internet provider (chat and then phone) where they tried different settings to make the wifi connection work on my phone. Unsuccessfully.
I didn’t have more time to spend on this issue over the week but I’ll try to call them again this coming week. I hope they can make it work!

It’s a very weird problem and people helping me from the internet provider had never heard of such a thing. Anyway, I’ll let you know if the problem is fixed and hopefully how. Maybe some other Fairphone users will be able to profit from it.

There was another thread opened for FP2 about wifi problems with 5GHz bands, you might want to have a look:

I finally got help from my internet distributor and they could fix the problem! :smiley:
If I understand right, what they did was actually the thing that was suggested from the other chat: to change the security settings from “WPA2 high secure” to “WPA/WPA2 very high secure”. I feel a bit stupid that I didn’t suggest them to try it last time I was getting help but this time apparently the guy thought about that solution just before I told him what was written here.

Anyway, case closed! But maybe others can know that this is actually is a working solution.

Thanks for the help and support!


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.