No wifi connection works with FP Open 16.12.0

Hello, all, n00b here. Sorry if this should be addressed somewhere else, but I did try to find the topic elsewhere without a solution to it.

I got my new FP2 in December and at first installed the FP OS, but yesterday I realized there is an FP Open to avoid Google. Hence I installed it yesterday, but now, no wifi connection is kept. It ives me the exclamation mark on every one I’ve tried (home, work, friend’s place and an open café wifi without password) and says “connection problems”.
Is there a workaround, or do I have to re-install FP OS and google’s services?

Much grateful for any help. I’ve rooted my phone, but I’m not a specialist in any way, so I didn’t really understand the answers in Can’t connect to Wifi but OK for 3G .

The easiest for you would be to open Amaze File Explorer, which comes preinstalled on Fairphone Open. Go to Amaze’s menu (swipe from the left) and enable Root Explorer in the settings.

Then go to the folder /data/misc/wifi ("/" is spoken root. It is like “C:” in Windows. Swipe left again and there will be an option that directly takes you to the root directory.) Delete the file wpa_supplicant.conf.

If that doesn’t work, attempt a fresh reinstall of FP Open.

Thank you, but it didn’t help :frowning:
It turns out I wasn’t rooted after the change of OS, that’s why I couldn’t understand the instructions on the /data files. Excellent explanation, though, much appreciated, so I did all that. But since it still says “Connection problem” (or “failure”, my OS is in Swedish), any other ideas?

And before I do a re-install, do I have to backup all apk:s etc? Or will they still be there? Sorry for asking n00b questions, but I hope you will bear with me.

And even more interesting: Even though I’m now rooted, I can’t enable “Root Explorer” anymore?!

If you install FP Open through the Updater app, only the system files get overridden. Your apks should be fine (of course it’s never bad to have a backup! :wink: )

Switching between FP OS and FP Open or viceversa deletes all the data. Reinstalling any of them from the same “OS flavour” don’t, AFAIK (never tried it, though).

Thanks, Roboe. I’m only used to Mac OS since 25 years, and installing a new OS version there usually does no harm, but I’m not sure how Android works in general.

Only I can’t really do it through the app, since it requires a Wifi connection … I did manage to get a nanosecond or so of connection, enough to stop it from saying “Connect to wifi”, but when I’m on the “Download started” window, it says “Just a moment” and has been saying so for a while.

I now installed the latest download through my computer and then via Amaze, and suddenly got the “Keep system Read Only” from TWRP on my screen. I pressed "Keep it Read Only, and now I’ve got the window with all the options. Am I to press Install, Restore or Reboot here?
(FYI: I simply don’t get the answer from this thread: Need advise to restore or re-install FP Open OS with TWRP )

1 Like

FP OS and FP Open are considered two different OSes because they sustantially differ in important system composition (remember that Google is deeply integrated into FP OS). I’m sure if you change between Mac OS and Debian GNU/Linux you’ll lose all your apps and data too (not data stored on a secondary HDD, though, as well as the microSD data on the FP2 is conserved)

For your TWRP issue, reboot to the system again and redo the process. Once the “Keep system read only” warning appear, select NO or similar. Installing a system update modifies the system in fact, you need to let it do that, :wink:

1 Like

Thank you, Roboe, again, much appreciated. Nice to see that someone else is not out partying :wink:

But: this time I never got the “Keep system read only” warning, I got directly to the window with many options :confused: Can I go somewhere in Settings/Developer options and get it back? If not, which do I then choose now, Install and then choose the zip file again, or what?

I’m afraid I didn’t get that, :confused:. Maybe a cultural breach? I’m from Spain, is it festive there or something?

Oh, yeah. Sorry, I forgot about TWRP’s persistent memory.

  • Safest choice if you’re not so tech-savvy: from your OS, just remove the .twrps file inside your TWRP folder with Amaze
  • Cleanest and quicker but slightly risky if you are not careful enough with touch-things: from TWRP itself, select the Mount option and uncheck the “Only mount system read.only” checkbox at the bottom of the screen and reboot again to the OS (don’t change anything more!)

I only meant that it’s Saturday. But perhaps you’ve not started your party evening yet, while I’m about to make it a night soon :smiley:

So now I’m in with the possibility to make changes. I chose Install and picked the .zip file, but it says “Failed”. Rebooting system now. Which one should I choose to get a re-install of the system?

Also: How come I can’t choose Root explorer anymore in Amaze? (See above, “Even though I’m now rooted, I can’t enable “Root Explorer” anymore?!”.)

Oh, I understand now. Not a party-every-week guy here, just eventually, :stuck_out_tongue_winking_eye:

Open the ZIP file with Amaze (select Updater when prompted). They should take care of the rest for you.

Don’t worry too much at this point; one you reinstall FP Open, you could enable root from the Developer Options without any trouble, :wink:

Went to Amaze and clicked the .zip file. When I then click restart, I end up in TWRP, still. That’s where I don’t know what to pick, since picking Install gives me a “Failed” message. Can I remove TWRP or work around it in any way?

Edit: I downloaded the “OTA – Upgrade from an earlier Fairphone Open build.” (first on the list on the page ) again now, , and now it seems to have re-installed the OS. However, the wifi problem STILL is the same, a brief connection for a second, then “Connection failure”.

So: Please, @Stefan and @Roboe (or anyone else) – any other ideas?
I have removed wpa_supplicant.conf, I have re-installed the OS, and neither works.

I have forgot to mention that Amaze gives me the error message “Amaze has unfortunately been stopped” on occasion, when I’m moving in and out of files there. Not sure if that’s because I also installed another File Manager?

Hmmm… The last time it worked was on Fairphone OS with GMS, right? Could you try to install that one to find out if this isn’t actually a hardware failure?

Beforehand you could try a “Clear Data” in TWRP, it might be worth a try…

I’ll try the Clear Data, but would you mind giving me a hands-on instruction for that? When and where do I see that option, what do I press before and after?

And yes, I might have to install FP OS with Gurgle, at least to double-check. The wifi worked fine on that OS.

In TWRP the command is called “Wipe”. I found this tutorial:

1 Like

Thanks, @Stefan, but it just keeps on bugging me…
Now I don’t know how to get into TWRP again. Volume up + power only only starts the updater … I removed the .twrps in TWRP in Amaze, but that didn’t help. (It did enter TWRP to run an Open Recovery script, but then restarted and gave me the normal desktop [or whatever it’s called]).
How do I “break into” TWRP mode now?

How can it start the updater? Power off your phone and do the Volume up + power combination. Doesn’t that work? :slight_smile:

Oh, “turn it off”. Yes, that worked :slight_smile: Thank you. See, I’m telling you, I need explanations like I’m a five-year-old :smiley:
Edit: Doing a backup first, and will get back when I’ve managed to wipe it, too.

1 Like