English

No Notifications

Hi, first time here, but I’ve been a fairphone user since the fairphone 1. Now on a fairphone 2, still love the idea but coming up against a problem I can’t seem to fix (although I haven’t fixed that many but have done work arounds :))
Now, the problem: In the past week or so my phone has stopped notifying me when I have any mail, interaction on facebook, twitter, instagram and whatsapp - in fact it doesn’t notify me of anything. On the main screen when I pull down the menu that includes wi fi, phone signal, battery etc I can no longer get the full menu, instead I have one line underneath which it says ‘no notifications’. I’ve read everything on the forum that mentions ‘notifications’ and have not found anyting like the apparent fault I am describing. I’ve opened the phone in safe mode but havent dared to do a factory reset as I don’t know where my data is backed up - help please!?

1 Like

Could you post a screenshot of the notification area?

No, I’m afraid not, I can describe it. On the top left hand corner is the time, top right hand is the settings symbol and a downward arrow. Below the time is the symbol for wi-fi, then what looks like signal strength but could be mobile data, next to that is the battery, then do not disturb (unselected) then torch(off) and the icon for vibrate (which I have selected) is on the far right. These are the only icons, previously this opened out to include all expected symbols/icons. Below them is written ‘no notifications’. I have checked all apps and have notifications selected for all. Can you advise? I’m stumped!

Well, as for getting all the icons to appear: you can swipe down on the notification drawer a second time, and the entire quick settings menu thing will appear.

But as for the notifications… this can have several causes. If you go to settings > battery > little three dot menu > battery optimisation, are all the apps that have to send notifications in the ‘not optimised’ section? I know for a fact that WhatsApp doesn’t work properly if it’s optimised.

Another, slightly more drastic option is to go to settings > apps > little three dot menu > reset app preferences. You’ll have to reset what kind of notifications apps can and can’t send, and if they can run in the background - if that’s something you’d set up before.

1 Like

OK, Many thanks for your time, I’ve gone through all the optimised for battery settings and set all the apps that used to notify me to ‘no optimised’ so will see if that works. I’m afraid the notification drawer still does not display as it did. This means that when the phone is plugged into my computer I can no longer unlock it to transfer files for example, I fear there is something more amiss.

That does sound like there’s something gone wrong with the system UI.

One solution I’m repeatedly coming across when searching for this is rebooting to safe mode, logging into the guest account (settings > users) and then rebooting again normally, and logging back into your usual user account. Something to try maybe?

Hi again, many thanks will try that, I posted on here in case anyone else was having the same problem, perhaps others will respond if they have. I’ll definitely try your suggested ‘fix’ thanks again.

Hi, I have the exact same problem. Additionally my “home” button and my “overview” button don’t respond (meaning that the screen senses the touch but nothing happens) so for example to exit an app I have to tap “back” multiple times.

1 Like

I’m having exactly the same problem. Were either of you able to solve it? The phone has also changed the settings so that typing, etc, vibrates, but I had that setting turned off before.

1 Like

Me too, I have the same problem: notification bar shows only first line, home button and overwiew button don’t work. Can’t see system UI, can’t change the user in “Guest” when I’m in the safe mode…
Tried to find the SetupWizard to repair the notification bar with Nova Launcher - couldn’t find.

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.