No mobile internet after "hard reset"

Hi there,
after experiencing an infinite boot loop quite shortly (but not immediatly) after updating to OS version 1.2.8 without seeing any reason for that, i made a hard reset.
Since doing so, I have no connection to mobile internet any more (WiFi, calls and SMS working fine).
I checked APN settings finding that the APN was not set to what it was before. Changing that to what it should be - and comparing the settings to what my provider suggests - did not help. (Yes, mobile data is turned on and phone is not in flight mode.)
In Settings -> SIM-cards there is nothing to configure except the name of the SIM-card.
The (only) card I use is already “preferred card” for mobile data, calls and SMS and I couldn’t change these settings as they are deactivated.
Changing the SIM-card to second slot did not help either.

Anyone else experiencing this problems? Any suggestions?

1 Like

Did you try the SIM in another phone? How old is the SIM?
I don’t think the hard reset is the reason for the connectivity issue, but rather the connectivity issue and the infinite bootloop have the same cause - which I would guess is the SIM, not the update.

Hi Paul,
thank for your input.
No, up to now I did not test the SIM (about three years old) in another phone.
How would you explain the effects, that

  • the mobile connection worked fine until the hard reset
  • the boot loop took place after having used the SIM in the phone for about two months without problems
  • calls and SMS are not affected

As far as i’ve read the topic about the boot loop, up to now nobody related the loop to problems with the SIM card.


To me it sounds still like a problem with the APN settings. Which is your provider?

Sounds also must plausible to me.
Cannot imagine that the hard reset would affect the hardware, and after the reset, software should be like on a new phone. So my guess would also be to try fiddling with the settings.

Well, yes - sounds also like APN-related problem to me.
But I double-checked the settings (more than two times).
Provider is O2 (reseller Drillisch, Germany).
I wonder wether the reset did leave behind some APN-related setting which are now in the way and prevent the correct settings to take effect.
After the reset the selected APN was not the correct one - and I do not remeber having changed the APN after switching on the FP the first time.

I’ve found this in another forum:

Ich habe es mit den folgenden APN-Einstellungen zum Laufen bekommen:

Gehe zu APNs (Settings > More > Cellular networks > Access Point Names - wie auch immer das auf deutsch heißt)Liste war bei mir leerOben auf "+"Die folgenden Daten eingeben:

Name: O2

APN: internet

(alles andere leer bzw. auf Standardwerten lassen)

Oben rechts auf die drei Punkte, dann speichern.In der APN-Liste nun auf den neuen Eintrag tippen, damit er aktiviert wird.


Wenn’s nicht direkt klappt, dann evtl. nochmal kurz den Flugmodus ein- und wieder ausschalten.


Hi Irina,

thanks - I tried that about a hundred times … no effect. :frowning:

And what is remarkable: Every now and then I get a notification telling me “SIM cards have been changed, tap here to configure”, which takes me to Settings -> SIM Cards.
Here I can configure nothing but the name of the card (and enabling/disabling) the card.

One more thing:
In the quick settings (two-times swipe from above), the icon showing the signal strengh (quite high) shows an exclamation mark - what does that mean?

The exclamation mark means, that Android cannot ping a google server.
(This is usually to show if your WIFI connects you to the internet as well).

WTF! (sorry!)

I really followed the post above - and it worked. :confused:
Before I always checked/modified the existing APN settings or created a new one with the (by my service provider) recomended settings.
Now, most of the settings are “empty” or “not defined”.

What keeps me wondering:
It seems that at first use (= first contact with SIM card / connecting to the phone service) the FP2 magically got/had the correct APN settings.
After the reset these settings had vanished.
In my eyes two options:

  1. At first use of the SIM-card, the serviceprovider sent the correct settings to the phone (but the “automatic settings via SMS”-feature provided by my service provider did not work now).
  2. The reset also deletes settings on the SIM card (hard to imagine).

Any ideas?

I’m glad it worked :slight_smile: . This APN stuff is really something very strange. But since so many people with so many different phones have the same problems, the answer can almost always be found on the web. Many times, the correct settings are not on the provider’s homepage, but another desperate user posted them in a forum. I’ve got the impression that in many cases the providers themselves don’t understand much more of the issue than we do…

Just in case someone wants to investigate further. I will stop here because it’s too confusing. :confused:
I tried to find out which setting prevented the correct connection.

  1. Changed “MVNO-Typ” to “None” (futher options: “SPN” / “IMSI” / “GID”, befor: “IMSI”)
  2. Activated these settings
  3. Mobile internet worked
  4. Changed “MVNO-Typ” to “IMSI” (futher options: “SPN” / “IMSI” / “GID”, befor: “None”)
  5. Activated these settings
  6. Mobile internet worked (why now?)
  7. Activated the other, newly created APN-settings
  8. Mobile internet went off, mobile internet went on again and the selected APN settings changed to the “old” settings (see 4)) - tried this several times because I could not believe it.
  9. Changed “MVNO-Typ” to “None” (futher options: “SPN” / “IMSI” / “GID”, befor: “IMSI”)
  10. Activated these settings
  11. Internet worked, I can switch between the two settings, both work, both stay active

I could “spin off” quite some theroies now - but without deeper knowledge of what these settings mean and how they interact with the phone network (and Android), these would not help much.

Quite happy that it does work now, I will start to set up the phone again (after another reset, manual re-installation of OS 1.2.8, wiping user-data and so on …)

1 Like

I have experienced exactly the same, @FairPhonerM !
My phone had worked well until I updated it to OS 1.2.8. While watching a video (battery at 64%), it shut down and got stuck in an infinite boot-loop. (After 3 days) I was able to get it working again for half a day, but while watching another video, my FP2 behaved exactly the same. Another few days went by until it booted correctly and yesterday I decided to perform a hard reset. Up to now, I have not come across any issues except the mobile internet issue mentioned here. So thank you @Irina_Spitznagel for having posted the solution! :slight_smile:
@FairPhonerM: When did your phone break down? Were you also watching a video/ doing something “demanding”? How does your phone behave after having reset it?

Hi TObi,
I can’t remember too good - as I wasn’t prepared to this :wink:
For sure: I had switched on Quickboot (an option I think is very useful).
I shut down the phone the second (maybe third) time after switching on Quickboot and it did not go off as fast as usual (I think it showed “android” while shutting down - unusual for Quickboot).
The next time I switched it on it stayed in boot-loop.
It seems to be quite reproducible - I had it two times shortly after switching on Quickboot, never with Quickboot switched off. (Second time I had a backup - saves quite some time!)

Thank you, this worked for me, too!
I lost mobile internet after receiving a new SIM card on the same contract (o2 Multicard).
The new card worked in my old phone, the old card works in my old phone, just the new card did not work in the FP2 (with FP Open OS) until I changed the MVNO type from IMSI to None.

Great to hear it helped.
Same thing happened with my FP2 again while switching to FairphoneOpen OS 16.06 (from FPOS GMS 1.4.2).

Oh Vielen Dank für die Lösung. Ich war schon am verzweifeln!

1 Like

Thank you very much, this made it work for me.

The funny thing is, when I tried to save an APN with other settings, it wouldn’t even appear in the list. But after trying this, it magically worked out!